1

I have created two site collections, one as an authoring site and another as a publishing site. The authoring site is enabled as a catalog and I am trying to use cross-site publishing to display a list in the publishing site.

I have a Content Search Web Part within the publishing site and have use the query builder to populate the web part with the contents of my list from the authoring site. But, the link for each item that is created does not display any information or go to what is in the list in the authoring site. The link just goes back to the main page of my publishing site.

What is the reason for my links all going straight back to my current publishing site instead of displaying/navigating to the item in the authoring site?

0

When you connect your publishing site to the product catalog (Site Settings > Manage catalog connections) there is an option under "Catalog item URL Behavior" that allows you to either" Make URLS relative to this site" or "Make URLs point to the source catalog". The latter is the default so my guess is that is the issue.

This is by far the best series of articles I have found relating to setting up the product catalog. How to set up a product-centric website in SharePoint Server 2013

  • I do have the "Make URLs relative to this site" selected now. With that selected, now my URL is a link to the publishing site. My URL is supposed to be as follows: /sites/Publishing/Term Root/Term/[owstaxidClient]/[ProjectNameOWSTEXT] – astout419 Jul 22 '14 at 13:19
  • So instead of pointing here: /sites/Publishing/Term Root/Term/[owstaxidClient]/[ProjectNameOWSTEXT] as I've specified in the catalog connection page, it points to here: /sites/Publishing. What is causing this??? – astout419 Jul 22 '14 at 14:03
  • I have not had good luck with that "use the default format provided by the catalog source" option. I use the third radio button "Construct a URL format from catalog properties" and do it myself. See this image: blogs.technet.com/cfs-file.ashx/__key/… – Robin Jul 22 '14 at 16:36
  • Robin, I have tried that as well, still no luck. The Navigation Links at the top work fine. A page has been created for the items in the Navigation Links and an item appears in that page. But when I click that item, I am returned to my root page. No catalog item URL appears to be created. I've tried everything I can think of and have found no articles/forums that address this problem – astout419 Jul 22 '14 at 23:44
  • I guess what I'm saying is: what is in the actual CSWP within my pages created for the navigation links, does not get a URL created for it. Why is that URL not being generated? – astout419 Jul 22 '14 at 23:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.