I have created my Machine Translation service and was able to start the service without any error. However, when I am trying to create or configure a Variation label and reach the 3rd step Translation Options, I get an error.

Cannot connect to the Machine Translation Service, contact your site administrator enter image description here

enter image description here


3 Answers 3


The timer job related to machine translation service may not be able accept or reply the request of IIS. Io resolve the issue you have to try the two following steps:

  1. Try by stop and start machine translation service in the central admin

if this does not resolve your problem.

  1. IISRESET and check the variation log will be enabled

Check the below tech-net fro troubleshooting the Machine Translation services.

Did you try to stop and start the MTS service?


  • Yes, I did. I even recreated my MTS but no luck
    – Joe
    Jul 14, 2014 at 2:44

You need to "Configure service application associations"enter image description here

default Application Proxy Group

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.