0

I created an email alert workflow in SharePoint 2010 using SharePoint Designer.

This email alert has images embedded in them using the HTML tag .

When i receive the email alert,it doesn't load in Outlook and also in mobile(Iphone).

Can someone help?

  • How are you referencing the image in the HTML part of the email? – Brandon C. Jun 25 '14 at 13:47
  • I'm using <img src="imageURL"> in the body section – George Jun 25 '14 at 14:29
  • Did this ever get resolved...I'm running into the same issue. – user42989 Jun 4 '15 at 13:01
  • Hi @TimWelsh,the email images got displayed in webmail but in outlook it didn't display for reasons unknown(may be since I was in VPN). IPhone issue was because of some security issues. When i used a image from google,IPhone displayed the image. – George Jun 4 '15 at 14:29
1

The problem that you might be having, is that your image is stored locally on the computer you are using. Know that when you create workflows and send emails, it is running on the server farm. So unless the image is also stored on your server, it will not appear in the email address, as the server cannot reference that image.

Try putting the picture into your sharepoint site, and reference the picture using the path along your sharepoint site from the workflow.

  • Hi Brandon,sorry I was not clear..I uploaded the image to the picture library and used that URL inside <img src> – George Jun 25 '14 at 15:59
  • Are you including it in the email itself? If you want to add HTML elements to an email, fist build the <img> as a dynamic string, and set it as a workflow variable. Then perform a lookup on that variable in the email itself. – Brandon C. Jun 26 '14 at 11:33
  • Hi Brandon..Yeah did the same. Also i see that these images are loading fine in OWA. But not in outlook and mobile. All users have access to the image location . – George Jun 26 '14 at 11:49
  • Can you post an example of the whole image URL source? You don'T have to actually give details, just descriptions, like masterpage/sites/mySite/images/myimage.jpg – Brandon C. Jun 26 '14 at 11:52
  • <img src="sitecollectionURL/sites/May20/Pics/EIS-ITALert%20Header.jpg" width="627" height="151" alt=""/> – George Jun 26 '14 at 11:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.