While trying to deploy a solution package in SharePoint 2010, it stucks in the deploying status.

I tried the follow steps but no success.

  1. Tried to the cancel the deployment from CA.
  2. Tried to cancel the deployment task using STSADM
  3. Tried to delete the deployment job from CA
  4. Tried to delete the deployment job using Management shell
  5. Delete all the corresponding assemblies from the GAC manually.
  6. Restarted the SharePoint Timer service.
  7. Tried to delete the deployment job using Management shell...
  8. Executed the "stsadm -o execadmsvcjobs" command..

Now, I'm neither able to deploy nor retract...

It throws the below error: Object reference not set to an instance of an object. Troubleshoot issues with Microsoft SharePoint Foundation. Correlation ID: f9bad4cd-bf3e-4533-9d70-1f143d95d018 Date and Time: 3/24/2011 2:12:03 PM

I want to completely remove the solution from the Farm, what else I can try?

  • Have you checked ULS logs for Correlation ID: f9bad4cd-bf3e-4533-9d70-1f143d95d018. Commented Mar 24, 2011 at 17:15
  • it just says object reference is not set to the instance of the object. I could not find anything else either from the ULS or in event viewer. Commented Mar 25, 2011 at 2:53
  • Have you tried using the Uninstall-SPSolution and Remove-SPSolution PowerShell commands? What happened when you ran those?
    – MichaelF
    Commented Mar 31, 2011 at 15:03
  • Yes, Still it throws the same error message...I think, there is no real solution package stored in the solution store however somehow it is registered in the DB. Commented Apr 1, 2011 at 6:02
  • Can you provide the ULS log there might be more information including a stack trace that can be used to diagnose the issue.
    – Steve P
    Commented Apr 5, 2011 at 5:43

2 Answers 2


This is quite common in SharePoint. In my case it usually happens in combination with the A web configuration modification operation is already running error. A potential solution can be found here.

By actually removing any associated assemblies from the GAC you may have made things worse as any feature receivers associated with the uninstallation process may cause errors due to missing assemblies.

Sorry for providing a generic Google search, but there are plenty of other people with this problem (and solutions). Have a look here.


Did you ever try to re-add the solution to the solution store? If that throws an error I would try to use the powershell way and the stsadm command to retract the solution.

  • Yes, tried to re-add the solution however it did not work. I could not retract the solution using both powershell and stsadm... Commented Apr 5, 2011 at 15:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.