4

On my SharePoint site I have 2 collections, '/' and '/sites/dev/'.

Everything works properly on the root site, but with with dev site collection any 2013 workflows that I publish are not being associated with the list they are created for.

I've used SharePoint Designer to create the workflow, and published to the list - but the workflow does not appear in the workflows section on the list in Designer or on the site (it does appear in the Workflows section of Designer though).

2010 workflows do publish correctly and are properly associated with the lists - so it's only the 2013 workflows that have the issue.

What can I do to get this working?

  • Are you using list workflow or reusable workflow? – Aanchal Jun 21 '14 at 5:59
  • It is a list workflow. – rwdial Jun 22 '14 at 17:36
  • Are you re creating your workflow for new site or using the same? – Aanchal Jun 22 '14 at 18:29
  • I don't understand what you are asking @Aanchal? I am attempting to create simple new (list) workflows on both sites. – rwdial Jun 23 '14 at 15:56
  • Have you tried with some other site? – Aanchal Jun 23 '14 at 15:59
1

Sometime this is because that the xoml and xsn files in the Sharepoint Designer (Navigation -> All Files -> Wokflows -> Workflowname -> the *.xoml and *.xsn files) are not checked in. There are couple of solutions: Clear SharePoint Designer Cache; Check Alternate Access Mapping; Check the required fields. For more information: Click here

Here is a similar thread for you to take a look.

  • 1
    Thanks for your response - I've checked All Files -> Workflows to see if the files were checked out, but the 2013 workflow isn't showing up in that list. The second link seems more like the issue I am having, but there isn't an answer for their problem either - I have tried publishing from multiple computers and the same thing happens. – rwdial Jun 23 '14 at 15:46
1

Make sure you click on the workflow in SP designer, then edit the workflow. SP Designer 2013->(Your Site)->Workflows->(Your Workflow)->Edit Workflow At the top of the page under "edit workflow" you should see the "Publish" button. Click this and then check you SP site for the workflow. (Your SP Site)->(Your SP List)->List Settings->Workflow Settings

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.