0

I'm not sure if this is a problem with VS2012 or with SP2013. We restored a reverted vm yesterday, and there were a ton of weird SP2013 problems we had to overcome. Then after we got a site collection up and running at the root of port 80, I opened Visual Studio. None of our projects build because they can't find the Microsoft.SharePoint.dll assembly.

I went into a project and removed the old/bad reference, and tried to re-add it. However Microsoft.SharePoint.dll does not show up when searching Framework assemblies. I did find it when browsing to C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\ISAPI. However even when I add the reference from there, the project still does not build. It cannot find SharePoint in the Microsoft namespace.

I ran a repair on VS2012 and installed the SP2013 tools for VS2012, but the issue remains.

  • What is the framework version of your project? – Aanchal Jun 20 '14 at 13:49
  • you said you restored the VM from previous day? how you restored it, from snapshot? – Waqas Sarwar MVP Jun 20 '14 at 14:32
  • Check if the project targets x64 platform. Sometimes this setting can change without obvious reason. – ExpectedException Jun 20 '14 at 15:13
  • Can you rerun the config wizard first?Secondly, if that doesn't work reinstall SP 2013 and run the config wizard. – userAZLogicApps Dec 9 '15 at 13:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.