0

Referring to this post http://blogs.msdn.com/b/infopath/archive/2007/01/15/populating-form-data-from-sharepoint-list-views.aspx

I am trying to create an XML Document data connection using a URL but when I enter this URL and click the next button I get the error below:

The file or folder name https://contoso.test.net/subsite/_vti_bin/owssvr.dll?Cmd=Display&List={32364DED-7FE3-4276-837C-F2AC62C04B81}&View={804CC528-34B2-4473-89DB-C4E766CACC95}&XMLDATA=TRUE&NOREDIRECT=TRUE contains characters that are not permitted. Enter different name.

In thing the issue is not with URL but with XML returned by the URL. I tried this URL in browser and get below XML –

<xml xmlns:s='uuid:BDC6E3F0-6DA3-11d1-A2A3-00AA00C14882'
 xmlns:dt='uuid:C2F41010-65B3-11d1-A29F-00AA00C14882'
 xmlns:rs='urn:schemas-microsoft-com:rowset'
 xmlns:z='#RowsetSchema'>
<s:Schema id='RowsetSchema'>
<s:ElementType name='row' content='eltOnly' rs:CommandTimeout='30'>
  <s:AttributeType name='ows_ID' rs:name='ID' rs:number='1'>
     <s:datatype dt:type='i4' dt:maxLength='4' />
  </s:AttributeType>
</s:ElementType>
</s:Schema>
<rs:data>
<z:row ows_ID='1247' />
<z:row ows_ID='1246' />
</rs:data>
</xml>
  • It's been resolved, i just try this from different machine. May be InfoPath Designer cache issue. – SBP Jul 10 '14 at 11:28
1

Try with following URL:

https://contoso.test.net/subsite/_vti_bin/owssvr.dll?Cmd=Display&List=%7BF8DA6205%2DABF1%2D4D03%2D82CC%2D60F9AD78170B%7D&XMLDATA=TRUE&NOREDIRECT=TRUE

Just Encode your URL.

  • Not worked by encoding url – SBP Jun 18 '14 at 11:48
  • what is you final url? – Aanchal Jun 18 '14 at 11:50
  • So when are you getting the above mentioned error? – Aanchal Jun 18 '14 at 11:55
  • so what is the issue? – Aanchal Jun 18 '14 at 12:01
0

Remove the { & } from the url and you will be fine. I strip the { from the URL see below.

 https://contoso.test.net/subsite/_vti_bin/owssvr.dll?Cmd=Display&List=32364DED-7FE3-4276-837C-F2AC62C04B81&View=804CC528-34B2-4473-89DB-C4E766CACC95&XMLDATA=TRUE&NOREDIRECT=TRUE

Check below article for the URL Protocol.

http://msdn.microsoft.com/en-us/library/office/ms478653(v=office.14).aspx

  • Stripping braces also not worked but it give me below error We can not connect to contoso.test.net/subsite/_vti_bin/…{32364DED-7FE3-4276-837C-F2AC62C04B81}&View={804CC528-34B2-4473-89DB-C4E766CACC95}&XMLDATA=TRUE&NOREDIRECT=TRUE Please make sure you are using correct web address. – SBP Jun 18 '14 at 11:50
  • is it typo, becuase i am still seeing the braces in the url? can you share the URL you are using....from _vti_bin to True.also share the error – Waqas Sarwar MVP Jun 18 '14 at 15:18
  • We can not connect to 'contoso.test.net/subsite/_vti_bin/… Please make sure you are using correct web address' – SBP Jun 19 '14 at 8:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.