2

I've created custom master page and set as a default one. The master page is working fine in all browsers but It will not working properly in IE. It will not affect the styles which we select for selected text from ribbon bar. see the detail the issue in image enter image description here

Help me to solve this.

  • 1
    you should inspect that paragraph with dev toolbar. perhaps you are customizing paragraphs with CSS. knowing the version of IE would also help, as you say it is a browser related issue. – Tiago Duarte Jun 17 '14 at 11:17
  • 1
    Within IE, what Document & Browser Mode is your masterpage forcing the site into? There are myriad issues with SP2010 if you drop the <meta http-equiv="X-UA-Compatible" content="IE=8"/> tag (or increment it up above "IE=8"). – Stevangelista Jun 17 '14 at 15:10
  • I have solved the issue by the IE=8....but I'm also facing the issue in chrome – Sameer Vaghela Jun 18 '14 at 6:11
  • In chrome when I'm editing the content editor webpart then it will not work for me.it will disable all the controls of ribbon bar – Sameer Vaghela Jun 18 '14 at 10:32
1

I had similar issues that came down to the metatag in my custom master. I had set it on content="IE=10," and then users started reporting they could not edit text in Rich Text fields on forms, could not open lists in Excel, and several other problems. Changing ti to IE=9 did not fix all the issues, so I had to set the metatag to IE8. That is the only way to correct ALL the problems that users were experiencing. I think the "real" answer is to upgrade to SharePoint 2013, but that is a major effort, and the client I'm working with is simply not ready to do that right now. Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.