1

I have a visual web part in which I have placed one taxonomy picker control to select the managed metadata for user.

The web part is going to be accessed by the anonymous users. But when as an anonymous users I click on picker it asks for credentials.

What is the way to make it accessible for the anonymous users?

1

Here is also one another way to solve this.

As the taxonomy picker page belongs to _layouts, by default, it is not available to the anonymous users. Hence, we should set the property of the page AllowAnonymousAccess to true.

Go to the _layouts folder and find the WebTaggingDialog.aspx and place the below code.

<script runat="server" type="text/C#">
protected override bool AllowAnonymousAccess
{
    get
    {
        return true;
    }
}
</script>  

Hope this helps other too.

Thanks

  • Please add more details from the link to your post, if the link breaks it will be of no help to future readers – Robert Lindgren Jun 17 '14 at 5:18
0

You are going to want to look over this blog post I found on setting anonymous access to application pages. This page because it is coming from _layouts makes it a application page.

http://blogs.msdn.com/b/zwsong/archive/2010/04/29/creating-a-sharepoint-2010-application-page-for-anonymous-access.aspx

Also have look on this one: Anonymous Users and managed navigation

  • 1
    Please add more details from the link to your post, if the link breaks it will be of no help to future readers – Robert Lindgren Jun 17 '14 at 5:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.