0

I tried hard to not have to post on the Forums but cannot seem to get this to work.

I am trying to fix this service where may have never worked. I've reviewed the official guide http://technet.microsoft.com/en-us/library/gg266382(v=office.14).aspx to ensure that this is setup correctly.

I have also referred to http://blogs.msdn.com/b/sharepoint_strategery/archive/2012/03/16/troubleshooting-sharepoint-2010-web-analytics.aspx and went through all troubleshooting steps. I currently turned up the Web Analytic logs from Central Admin -> Monitoring -> Configure Diagnostic Logging) where I hope to find some errors.

I have also read around which generally say the same types of things to check in the second article. I do not want to create a new Web Analytics server if I don't have to.

So the main things I have covered are:

  • Ensuring the Web Analytics Service Application + Proxy are started.
  • Verify that a .USAGE files are being created. ** NOTE: I actually only see one generated.
  • Looked at RequestUsage view to see that entries were being updated.

Any suggestion would be much appreciated at this point.

  • Did you browse from the central admin > monitoring > reporting ...View Web Analytics reports , what you see here? when you configured Web Analytics, you need to wait atleast 24 hours to see the results. How big is the sharepoint farm is? – Waqas Sarwar MVP Jun 13 '14 at 15:37
  • did you perform all the checks mentioned in the blog and what are the results? – Waqas Sarwar MVP Jun 13 '14 at 15:38
  • I did run the report. Basically I get 0 for all Values except for Total number of sites. If I run it for the collection, I get only the Total # of sites and Total Storage Used. – LEEMAN Jun 13 '14 at 15:40
  • 1. They are both started. I restarted it anyway. 2. There is 1 .USAGE file in the folder which is current (date modified) 3. Checked the RequestUsage view sorted by log time desc and the dates are current.<br> 4. There is nothing that indicates exceeding bytes. I have turned up the logging as mentioned and will be checking this again. 5. The date for this is current. 6. The date for this is current. 7. Waiting for more logs. – LEEMAN Jun 13 '14 at 15:41
  • Sorry for editing. I am learning the markups now. – LEEMAN Jun 13 '14 at 15:45
0

Okay I totally missed something but just wanted to post where I messed up for anyone else having the same problem.

My problem was a mixture of database permissions I had to set. I found the errors in the ULS logs. I also had to change NTFS permissions and members in group for some reason (I inherited this project).

Basically what I didn't realize while working on the app server, I needed to be working on the web server and there the Web Analytics service was disabled. I also had to setup permissions on this server because the ULS log folder had empty 0kb files and wasn't producing USAGE files. After I did that it started populating today.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.