0

I have a small issue or a big one ...

So I have a SharePoint 2007 where a solution build in visual studio 2008 is deployed. Recently i've started to develop in 2010, i converted the solution to the correct format for the visual stiod 2010. Everything was converted more or less ok, i checked the manifest files they were identical for both solution.

But when I try to upgrade the solution in 2007 with the new solution, i get the following error:

The solution file located at "package.wsp" does not appear to be a valid upgrade for solution "package.wsp".The two solutions must have the same resource types (global or Web-application scoped).

Any idea how to solve this? And what could cause this error?

All the features seems to be deployed withthe correct scope and the resource files also.

  • Basically you convert the code and compile it for 2010, then why you need to deploy it 2007 instead of 2010. 2010 code in 2007, what i am guessing the backward compatibility issue. – Waqas Sarwar MVP Jun 12 '14 at 15:23
  • no i didn't really change the code, i only migrated to visual studio 2010, with the correct structure etc .. and it is needed to be able to develop on VS2010 and still deploy in sharepoint 2007 – Shkipper Jun 13 '14 at 12:55
  • what you trying to do, update the solution(update-spsolution) or removing the old and adding / installing new solution(install-spsolution) – Waqas Sarwar MVP Jun 13 '14 at 13:01
1

It possibly missing safecontols declaration node in manifest file.

it should look like this:

<Assemblies>
    <Assembly Location="Assembly.dll" DeploymentTarget="GlobalAssemblyCache">
      <SafeControls>
        <SafeControl Assembly="Assemmbly info" TypeName="*" Safe="True" />
      </SafeControls>
    </Assembly>
  </Assemblies>
0

Have you checked and compared the features being deployed with the package? Check the manifest file to see if the deployment scope is correct, also would suggest to retract, delete, add and deploy the whole package again to check.

  • Yes, i did check the features and they are all the same. The thing is i can deploy it, but i need to make it sure it upgrades correctly. The manifest files are more or less the same, except in vs2010 solution it declared some safecontrols for my assembly ... but i doubt that this could be the issue ... – Shkipper Jun 13 '14 at 6:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.