1

I've been doing some testing in sharepoint 2013 and I have come accross a rather annoying situation regarding the authentication. I have both windows authentication and forms authentication working. The forms authentication checks the creds against active directory on a DC.

The scenario in which I need both:

Windows; Fred logs in locally (internal) and is signed in automatically.

Windows; Fred logs in externally using an internal VM and is signed in automatically.

Forms; Bob is on an external network but has an internal active directory account. He then enters his internal AD creds.

The reason for this is that only users with an active directory account can access the site due to security.

Problem Outline

I have the following active directory account: Username - User1 Fullname - User Name Password - Monkey

So if I log into sharepoint using windows authenication it will recognise me as "Name, User", the issue arrises when the same user logs in via forms. It recognises the same account as "User1".

How can I get round this?

  • Have you made any progress on this? We're having the same issue and are still trying to find a working solution. – dspencer Jun 19 '14 at 17:28
  • See my answer :) I hope it sorts your issue. – Heberda Jun 25 '14 at 12:03
0

After quite a lot of searching and blog reading the unfortunate solution I have come up with is that it's not possible for our network.

Basically, sharepoint does not or cannot connect profiles from two different authentication models.

There is however a work around. ADFS offers both windows automatic sign on and forms sign on thus sharepoint thinks it's only using one provider. This would solve the question raised, unfortunalely it doesn't solve my issue because ADFS is incompatible with our infastructure.

I hope this helps :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.