1

I am trying to setup Secure Store Server and after successfully creating the Service and the Proxy I am greeted with this error when I attempt to manage it.

Cannot complete this action as the Secure Store Shared Service is not responding. Please contact your administrator.

The Event Viewer displays this error.

Log Name:      Application
Source:        Microsoft-SharePoint Products-Secure Store Service
Date:          3/18/2011 4:49:28 PM
Event ID:      7557
Task Category: Secure Store
Level:         Error
Keywords:      
User:          
Computer:      
Description:
The Secure Store Service application Secure Store Service is not accessible. The full exception text is: There are no addresses available for this application.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Microsoft-SharePoint Products-Secure Store Service" Guid="{73541538-24DA-4282-AE1C-3A6321C23FB8}" />
    <EventID>7557</EventID>
    <Version>14</Version>
    <Level>2</Level>
    <Task>1</Task>
    <Opcode>0</Opcode>
    <Keywords>0x4000000000000000</Keywords>
    <TimeCreated SystemTime="2011-03-18T23:49:28.407358400Z" />
    <EventRecordID>143074</EventRecordID>
    <Correlation ActivityID="{7E4AEA87-6F45-427F-86C2-7605489D1130}" />
    <Execution ProcessID="9456" ThreadID="3548" />
    <Channel>Application</Channel>
    <Computer></Computer>
    <Security UserID="S-1-5-21-798254582-200106796-1537874043-166173" />
  </System>
  <EventData>
    <Data Name="string0">Secure Store Service</Data>
    <Data Name="string1">There are no addresses available for this application.</Data>
  </EventData>
</Event>

Any ideas?

1
  • Any news since ? Did you tried to reset IIS ?
    – user20250
    Oct 18 '13 at 17:06
2

Logon to Central Administration.

Click Application Management > Manage Service Applications.

Click Secure Store Service and then click Permission in Ribbon. Add System Account and set Full Control.

Regards.

3
  • Thanks for the reply but it is still not working. Same errors show up.
    – ChiliYago
    Mar 21 '11 at 17:29
  • 1
    Then why its marked as answer? May 6 '16 at 6:54
  • The Secure Store Database contains sensitive information. It should never be set to a generic or system account. It should have it's own dedicated user and app pool.
    – s31064
    Apr 14 at 22:28
0

The account that runs the Secure Store Service (SSS) application and IIS application pool should be a dedicated account, due to the sensitive nature of what that database contains. (The name "Secure Store" should give your first clue.) That account requires "Logon as a Service" and Logon as a Batch" rights, otherwise the app pool will keep stopping. Nine times out of ten, this is what I've found the cause to be, if the more well known issues don't fix the problem. This is a pretty complete checklist if you're getting that message:

  • Make sure SSS is actually provisioned. You can do this with PowerShell, and it's all over the web. I'll include it here just for completeness:

$service = Get-SPServiceInstance | Where-Object {$_.TypeName -eq "Secure Store Service"} $service.Provision() IISRESET

  • Make sure that the “Security Token Service Application” service is running within SharePoint.
  • Make sure the following Windows services are running (services.msc): Claims to Windows Token Service (this account also needs Logon as a Service and Logon as a Batch rights Net.Tcp Port Sharing Service SharePoint Administration Service SharePoint Timer Service
  • Make sure the following services are running within SharePoint (Services on Server): Claims to Windows Token Service Secure Store Service
  • Make sure your Farm Account and your SSS service account have Full Control permissions to the Secure Store Service in SharePoint (Manage Service Applications)
  • As I said above, make sure your SSS service account has Logon as a Service and Logon as a Batch rights

Once you make sure all of this is correct, do another IISReset, and you should be good.

-1

Did you check to make sure the forefront identity service is running? You may have to restart it.

Here are a couple other suggestions that I came across.

http://blogs.technet.com/b/manjesh/archive/2011/03/06/sharepoint-2010-unable-to-start-upa-sync-service-stuck-at-starting.aspx

http://social.technet.microsoft.com/Forums/sharepoint/en-US/7c8a9f65-a7bc-4c10-aecb-983398427f71/getting-there-are-no-addresses-available-for-this-application-in-sharepoint-server-2010-while?forum=sharepointadminprevious

1
  • This question is about the "Secure Store Service", not the "User Profile Sync Service". Jun 28 '18 at 12:31
-1

Having had a very similar problem, along with many other associated problems, which put my work at an altogether unacceptable, extended standstill, I decided to post the resolution I found to as many forums relating to this issue that I could.

The resolution that I found was one of two things that I did at the same time. (duh – not a smart tactic, but I was getting desperate…) I am not willing to spend the time to isolate the effects of each of these motions, so it could be one, or the other, or both.

  1. I noticed that SharePoint was moving the Farm Account Security Managed Account (The user account that Farm Account uses for credentials) from the Administrators group, to the WSS_ADMIN_WPG group. In my case Central Admin was being run on the same machine as the SharePoint Server. I run a single server developer environment. So the Farm Account needed “Log on Locally” privileges. WSS_ADMIN_WPG group did not appear to have the needed privilege, where the Administrators group did. Strangely enough though, the Administrators group is a member of the WSS_ADMIN_WPG group. So I moved the above mentioned user account back into the Administrators group.

Let me know if I’m not seeing something here….

  1. Upon examining the SecurityTokenServiceApplicationPool (the name I gave for the Security Token Service’s Application Pool), I notice that the Enable 32-bit Applications setting under the Advanced Settings had been set to True. This to me was strange as I remembered installing the 64 bit versions of everything, because the Server machine on which I was working was indeed 64 bit. So I set it to False.

After those two simple motions I did all the familiar and necessary things to be done to make sure that the system and SharePoint was running with all the latest settings and tried what I had been doing once again, and to my amazement and shock (after having tried everything on the internet several times each) it worked! I am now happily moving forward in my work! At least until the next roadblock comes along.

Weird, dumb and stupid, what were the chances? Maybe it will be worth a quick look for you.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.