3

I am working on a migration from 2010 to 2013 and have setup a development farm. I need a way to disable all outgoing emails or have all emails go to me. I have searched but can not find anything on disable emails. Does anyone know how I can do this?

  • 1
    Wouldn't change the outgoing email-server to something else work, or am I reading your post to literally? – Robert Lindgren Jun 9 '14 at 18:20
  • That worked perfectly, I just had to remove the mail server from the list of servers within the farm. Thanks – Grady D Jun 9 '14 at 18:23
  • Glad to hear that :) – Robert Lindgren Jun 9 '14 at 18:25
3

I know, one method which i used in my test farm. Basically i remove the all settings from the Outgoing email setttings from Web App.

For Single Web App:

  • Central Administration > Application Management > Manage Web Applications.
  • On this page click on the web application name then from ribbon Select the Outgoing email settings( if click drop down of General settings).
  • Now remove the Outbounf SMTP server name and other settings.

this will disable outgoing emails for the web application.

For the complete farm, you can remove the same setting

  • Central admin > System Settings > Configure outgoing e-mail settings.
  • On this page remove all the values.
  • 1
    As a side note this does not work if the mail server is listed under servers. This is what I tried but had to remove my mail server first. – Grady D Jun 9 '14 at 18:45
1

I had a scenario where I had to turn of mail for certain web applications but I did not want to disable outgoing mail totaly. It is a testfarm.

I used this script to set SMTP server for each Web Application with url that contains sp2010. Where "turnedOff" is a false smtpadress to make sure the webapplications does not use the default SMTP set for the farm.

$wa = Get-SPWebApplication | where {$_.url -like "*sp2010*"}
foreach($wp in $wa){
$wp | Set-SPWebApplication -SMTPServer turnedOff
$wp.update()
}

or for simply 1 web application:

Set-SPWebApplication -Identity "http://someURL" -SMTPServer TurnedOff

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.