6

I am getting an error message during installation of SharePoint Server 2013.

I have selected complete server option (other option is stand-alone).

When I am on 'SharePoint products configuration wizard' and give local account then get following message:

The specified user xxxxxxx is a local account. Local accounts should only be used in stand alone mode.

  • Is this a standalone development environment? – webdes03 Jun 9 '14 at 13:20
12

I think you are trying to install Stand alone deployment and using the config wizard to create the configuration database using the local account. In this case you have to create the powershell command to create config DB 1st then run the config wizard.

Run this command.

New-SPConfigurationDatabase

Hit Enter and it will ask couple of question i.e Database Name, Database Server, FarmCredential, PassPhrase. After providing these, wait for couple of min once it created then re-ran the config wizard.

http://sharepoint-bunny.blogspot.com/2013/08/sharepoint-2013-installation-with-local.html

enter image description here

  • 2
    For the OP, note that local accounts are not technically supported for SharePoint, and should be used only for local development environments. You should not use local accounts for a production environment. – webdes03 Jun 9 '14 at 13:38
0

For sharepoint 2016 use below format :

   New-SPConfigurationDatabase –DatabaseName SharePoint_Config –DatabaseServer <Server name> –AdministrationContentDatabaseName SharePoint_Content –Passphrase (ConvertTo-SecureString Qwerty12345 –AsPlaintext –Force) –FarmCredentials (Get-Credential) -localserverrole SingleServerFarm

Source : http://www.enjoysharepoint.com/Articles/Details/sharepoint-2016-new-spconfigurationdatabase-server-role-parameter-is-required-when-21264.aspx

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.