I've been trying to find a cause for this error for some time to no avail...

We have a SharePoint 2007 site heavily customized in terms of look and feel.

In the master page a user control has been inserted that uses an update panel to partially render updates in the control.

The User control seems to work fine on all pages unless a search web part is inserted into the page.

The control has a DropDownList that according to user choice hides or shows different panels. There are also buttons that cause async postbacks within each of the panels.

When a "Search Core Results" webpart is inserted into a page, all async requests cause a javascript error and no updates occur in the update panel.

The javascipt error is:

Sys.WebForms.PageRequestManagerServerErrorException: Object reference not set to an instance of an object.

The problem is I can't even figure out what this object is. It seems to be the ScriptManager (although its there in the master page).

Is there a way to get a detailed description of this error? Also, are there are any known conflicts or issues with update panels and SharePoint search web parts?

4 Answers 4


How about using Fiddler to inspect the content going back and forth? See what's different with/without the search webpart?


Have you tried setting the EnablePartialRendering to false in the ScriptManager to get a more descriptive error?

<asp:ScriptManager ID="ScriptManager1" runat="server" EnablePartialRendering="false"/>

I tried that, I don't get any errors and control functionalities seem to be working fine, but some scripts that are dynamically attached to some controls stop working.

The scripts are attached through ScriptManager.RegisterStartupScript in the SelectedIndexChanged event.


Just tried fiddler. In the request, the only difference I see is that without the search webpart it contains an NTLM authorization header, while the request on the page with the webpart has no authorization header.

In the response, the page that works has a private cache-control with some cookies set (i guess for authentication), while the other no-cache nor cookies set. Also, the response text contains the updated control when it works, while the other page returns this:

53|error|500|Object reference not set to an instance of an object.|

Could authorization be the issue here?

Wanted to add this as a comment rather than an answer but I can't see the add comment under any answers but mine?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.