2

I am not the developer and I need to deploy a solution by add-SPsolution with WSP file. I don't have Visual Studio to make change like Overwrite="TRUE"

During my first deploy, everything goes fine except the page loading the custom solution (a user control) throw error.

So I tried to Deactivate the solution in Site settings -> site collection solution. Then re-activate again to find the titled error..

What can I do? Do you think remove entire site collection and re-create can fix?

  • 1
    Have you tried deleting said field ? Make sure it's not actually used before doing that though. You can access the field edit page like this on your site/web : mysiteurl/_layouts/15/fldedit.aspx?fieldId=465a07bb-bb4f-4ec5-8ff9-e4c54f6d726b and replace with your field id – Cameron Verhelst Jun 6 '14 at 9:39
  • Cameron, I got error for the url after replaced my fieldID. Like "Exception of type 'System.Web.HttpUnhandledException' was thrown. ---> System.ArgumentException: Invalid field name. " – Mark L Jun 6 '14 at 11:12
  • Hmm, using an invalid GUID throws a field not found kind of error so that's not it. Are you using SP2010 or SP2013 ? I tested this on SP2013 – Cameron Verhelst Jun 6 '14 at 11:17
  • was this the error jshidell.com/2014/01/07/… ? Are you sure you used query string parameter FieldId and not Field ? – Cameron Verhelst Jun 6 '14 at 11:20
  • I delete the site collection and start everything from new. It seems work around the issue. Thanks for your help! – Mark L Jun 11 '14 at 7:24
0

I delete the site collection and start everything from new. It seems work around the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.