2

So our SP2013 homepage has 4-5 "apps" from the SharePoint store. Anytime a Mac user uses Safari to go to our site they have to enter their credentials for the site and then each app.

Anyone figured out a way to make SP play nice with Macs?

2

1 Answer 1

1

Pre-requirements:

  1. You need to use the most up-to-date Safari as your browser. To ensure you are using the most updated software check for updates in software updates.Once you’re in software update click “Check Now” and then install any updates that are found.
  2. Office for Mac 2011 needs to be installed for the SharePoint plug-in.

First time (and hopefully only once) setup: Note: Unfortunately you will have to do this several times. I had to do it a total of about 20 times going through our entire site due to the “apps” wanting authentication as well. Make sure you follow these instructions each time you enter your credentials so you never get prompted again.

  1. Open Safari and go to your site.
  2. At the prompt for authentication, enter "domain\username." Entering the “domain” is important.
  3. Enter password
  4. Make sure you check the "would you like to remember this password in your keychain" checkbox.
  5. Once you get through all the credential prompts you need to go to Safari > Preferences > Security > Manage Website Settings a. Select the SharePoint Browser Plug-in and change the “when visiting other websites” to “Allow Always”, and any sites listed in configured websites to “allow always”.

Note: You will have to change the password in Keychain anytime you change your password.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.