0

I have a workflow in SharePoint Designer where I'm kicking off a Start Feedback Process workflow:

Workflow

and it was running fine, but at one point I republished it and now I'm getting everything twice (tasks, emails, etc.), there's even duplicates of all the options:

Options

It feels seems like it's running twice but I can't see how or why. There's only one instance of the main workflow running, and the workflow history shows the logging twice when I run it once. Basically just looking how to either kill one instance or get it back to running just one time. Any thoughts/ideas would be appreciated!

1

Please check if workflow is starting on item updating or not.

You can also check from workflow setting if there are two workflows attached, If yes then remove the old version of your workflow.

Detailed steps are mentioned here:

http://technet.microsoft.com/en-us/library/cc262779(v=office.14).aspx

http://technet.microsoft.com/en-us/library/cc262779(v=office.14).aspx

  • Great suggestions. The workflow is set to only start when an item is created (and on change is not checked). I removed all of the instances (except for the couple that have active workflows), and had a good feeling about that but unfortunately no dice. – Sean Regan Jun 4 '14 at 22:25
  • This really pointed me in the right direction. I removed all of my instances (except the active ones), republished the workflow (twice - the first one threw an error), and that did the trick. Thanks so much for your help! – Sean Regan Jun 4 '14 at 23:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.