2

I am creating a Site Collection with this powershell command $createdSite = New-SPSite -Url $SiteUrl -Name "Site Name" -Template "CMSPUBLISHING#0" -Language 1033 -OwnerAlias "spadmin"

It used to work some couple of hours ago with 2013 experience version but suddenly it has stopped working and sites are being created with 2010 experience version. No matter if I delete the Site Collection, Web Application, restart server, recreate the Web Application with different port and DataBase Name that always the 2010 version appears and in this way.

enter image description here I have also tried to specify CompatibilityVersion -15 but no luck.

Does anyone have experienced a similar issue?

Some hours ago, it worked and now it only works if I select a different publishing template like BLANKINTERNET#0

  • 1
    for me something corrupted on hive folders, can you run the Config wizard on server, without disconnecting the server to the farm and keep everything as is and after that try again...Config wizard will re registered all dependencies etc. – Waqas Sarwar MVP Jun 3 '14 at 20:53
  • No luck. I will reinstall the virtual machine. – Alvmad Jun 4 '14 at 9:25
  • After reinstalling the virtual machine the problem remainss I don't know why with CMSPUBLISHING#0 the look and feel is 2010's and BLANKINTERNET#0 is 2013's. Yesterday, the look and feel of CMSPUBLISHING was 2013 UI. – Alvmad Jun 4 '14 at 14:16
  • how you rebuild the VM, did you re install the SharePoint from scratch? what about the databases, new or using the old? also did you try to create the site collection from central admin? – Waqas Sarwar MVP Jun 4 '14 at 14:48
  • 1
    try this code: Get-SPWebTemplate | Where{ $_.Title -eq "Publishing Site" } | ForEach-Object{ New-SPSite http://<site name</sites/test -OwnerAlias DOMAIN\jdow -Template $_ }.........replace the url with the your desired url and id) – Waqas Sarwar MVP Jun 4 '14 at 15:04
1

I had the same issue, and in my case I had to use the CMSPUBLISHING#0 template because I was moving a subsite to a site collection.

My solution was change the masterpage. Although seattle masterpage was chosen, I changed it to the oslo masterpage and worked fine, the 2013 layout experience came back. After I changed once more to seattle masterpage, and It worked perfectly. I hope this will be a solution for your case too.

By the way, if you can't access the configurations page, just add /_layouts/15/settings.aspx to the end of your site collection URL and you will be able to change the masterpage.

1

You need to add a parameter to specify the version:

-CompatibilityLevel 15

Without it, you may find it using the version 14 template by default because both 14 and 15 use the same template names.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.