0

I am trying to create a Subsite using Enterprise Search Template. While creating I am getting the below error. My site collection is Claim Based Authenticated.

enter image description here

Not able to figure the error. If anyone also faced the same error please give some idea.

Thanks

0

Two things come to mind. Are you using a custom master page, if so does it error out with out the master page?

Second, the Enterprise Search Center is a publishing site and is (generally) provisioned as a root web of a site collection. It has dependencies on Publishing and several other features.

If the root web of your site collection is not a publishing web (for example if it is a team site) you will encounter errors.

If you need the site to be navigationally under your top site you can create an explicit managed path "/Search" and then create the Enterprise Search Center under that Managed Path.

  • Thanks Matthew. My root site is a team site. So will I not be able to create a Enterprise Search Center? – Sushri Jun 4 '14 at 9:33
  • Not unless you turn on all the publishing features at the root. The alternative is to create a Managed Path as I described. – Matthew McDermott Jun 4 '14 at 15:43
0

i know this post is quiet old but as i stumbled across the same problem and could not find a lot of information after a lot research i found one thread with the correct google keywords. So the solution to this problem is to refresh the cache accounts for the web applications like it is described in the following Link (The last post.) I will copy the summary here:

The solution is simple enough just refresh the cache accounts for the web applications and this will set the user policies correctly. In Powershell it would be:

$PortalWebApplication = Get-SPWebApplication -Identity "Portal"

$PortalWebApplication.Properties["portalsuperuseraccount"] = "DOMAIN\SP_CacheSuperUser"

$PortalWebApplication.Properties["portalsuperreaderaccount"] = "DOMAIN\SP_CacheSuperReader"

$PortalWebApplication.Update()

After this i also did the Timer and IIS Reset.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.