2

I have been chasing up an error and am struggling to resolve.

I can browse my SharePoint site fine the only issue is Excel web app features do no display correct that's apparent to users

However in Central Admin I have noticed a few things. Application management -> Manage Service Applications

if i click on the User profile service application is returns an error saying - Something went wrong - ULS shows

Microsoft.Office.Server.UserProfiles.UserProfileApplicationNotAvailableException: UserProfileApplicationNotAvailableException_Logging :: UserProfileApplicationProxy.ApplicationProperties ProfilePropertyCache does not have 3b7bec6d-5d0d-4d36-8deb-1f575a4d4248

the UPS proxy wont start either i have tried - removing it and also re-provisioning it via powershell. But still no luck.

When I click on the "managed metadata Service" which is linked to the UPS (is it not?) it displays

The managed metadata service or connection is currently not available, The application pool or managed metadata web service may not have been started please contact your administrator

When I check the ULS logs there's error

Failed to get term store for Proxy 'Managed Metadata Service'"............ "The URL Format was invalid

Finally I get in windows event viewer 8306 claim authentication errors -

An exception occurred when trying to issue security token, The URL format was invalid

What can I try to resolve these issues? I am assuming there all caused by a common problem "the URL format", however my knowledge is limited.

  • I would check to ensure that the UPA is available to all the services and the CA. You need to check the service application association settings (Both Webs and applications) – Heiko Hatzfeld_MSFT Mar 24 '18 at 10:48
0
  1. Goto central admin, Select Web application URL and click on User Policy --> For all required admins,Farm account users provide permissions as all zones with full control.
  2. Go to UserProfile service(Any SA) and select the Permissions option and all above users give the same permissions.
  3. Disable the firewall settings in all Farm servers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.