6

I've been getting trying to get the search crawl to work on an internal document store for my department. I keep getting the following TopLevel error :

An unrecognized HTTP response was received when attempting to crawl this item. Verify whether the item can be accessed using your browser. (Error from SharePoint site: WebExceptionStatus: TrustFailure The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel.)

From the research I've done, I can fix this issue by setting Ignore SLL Warnings to "yes" under Farm-Level Search Settings. I have done this, yet I continue to get this error. I went ahead and added the site cert into the Trust Relationships under Manage Trust and I still get the error.

I'm at a loss here and any help would be greatly appreciated.

  • Might not be relevant, but is the default AAM for the web app set as HTTPS? I had an issue with Search crawls a while back where if the URL put in the Content Source wasn't the same as the AAM for the Default zone, it ran into all sorts of problems. – Thomas Gass Jun 19 '17 at 15:07
2

what i believe your certificate is not right. you need Root Ca certificate from your SSL certs.

try this link. http://www.appdelivery.com/2012/08/sharepoint-2010-crawling-ssl-enabled-sites/

other thing, i would try to reset IIS on all server in the farm and then run the full crawl.

  • A Reset of IIS did not change. You are correct though, our cert and website name did not match exactly. I thought Ignore SSL would do just that, ignore. But either way, I changed the content source to match the cert URL and it successfully crawled. But now I'm back to what got me here in the first place. None of my docs show up using the search still. – user28293 Jun 3 '14 at 14:36
  • that's the new issue, check the Crawl log what error you are getting? I would recommend close this question if it solve the above problem and open a new question so that community benefited from it. – Waqas Sarwar MVP Jun 3 '14 at 14:48
  • The link you mentioned is broken. – Achiever SP Jul 17 '18 at 16:08
2

I came upon this question after having this issue when we renewed our SSL cert. The search service was crawling continuous and must have cached the old cert some how.

I ensured the old cert was deleted form the server and then restarted the search services using services.msc. I started a full crawl and everything worked.

  • How did you ensure the old one is deleted? I am facing the same issue for my Dev environment, after changing the self signed certificate. – Achiever SP Jul 17 '18 at 16:07
  • In IIS's configuration for the server in question. The old certificate was still installed on the server that was being crawled. I verified the new certificate was being used in IIS, then deleted the old one. – Robert Kaucher Jul 17 '18 at 16:58
  • You should also do an IIS reset on the site being crawled after you switch to the new certificate. – Robert Kaucher Jul 17 '18 at 16:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.