3

I am using SharePoint 2010. We have a list where a user (group) has Contribute permissions but are not able to click on the "Add new item" button in the list. When they click on the button, it throws an Access Denied error.

In the Advanced Settings of the list, I have confirmed that users can create and edit all items. We have tried breaking and re-inheriting permissions. When we break permission inheritance, the group cannot even view the list. When permissions are re-inherited, the group can view the list, but they cannot add a new item to the list.

Does anybody have a suggestion on how to resolve this?

  • 2
    Does this page have any custom css or javascript present that may have been uploaded, but not checked in as a major version and approved (if necessary)? – Eric Alexander May 28 '14 at 3:55
2

A couple of things to check:

1) Verify that the user in question definitely has Contribute permissions on the list by browsing to List Permissions, clicking "Check Permissions", adding the user name, and clicking "Check Now".

2) Verify that the Contribute permission level has "Add Items" by browsing to http://yoursite/_layouts/editrole.aspx?role=Contribute

  • I have confirmed both 1 and 2. So, I don't know why they're still having trouble adding items to the list. – SP2010 May 27 '14 at 22:47
  • Have you tried granting the user Contribute on the list outside of the group? Have you tried this with other users? Perhaps also try creating a new list on the same site and granting the same user Contribute - does that work? – Phil Greer May 27 '14 at 22:54
  • I tried granting a user Contribute access directly to the list outside of the group. It didn't work. I also tried approving the access request message that they can submit when they see the Access Denied window. That didn't work either. The users have Contribute access to other lists on the site, and those lists are working just fine. – SP2010 May 27 '14 at 23:11
  • I had a problem recently where the list, the page that it resided on, and the site which the page resided on were not synced properly (all three had different permissions). I gave them contribute and they still had nothing. I had to drill down into each re-inheriting the permissions from the main site, and then the new user could get contribute permissions and access the list/page/site. – Pᴀᴜʟsᴛᴇʀ2 May 28 '14 at 0:21
  • The page does not inherit from the site. However, I am only the admin (Full Control) of the given page. So, I can't change anything about its inheritance. The list also does not inherit from the page. We tried re-inheriting, but that didn't work. – SP2010 May 28 '14 at 12:57
2

Are there lookup fields in the list? If so, ensure the user has read permission to those lists.

  • There aren't any lookup fields in the list. – SP2010 May 28 '14 at 12:58
  • I just tested whether I could add a new item (since I have Full Control). I cannot. Users are also reporting that the Links list / web part does not appear on the page anymore (they all have Contribute access), whereas I can see it (with Full Control access). Since the given list is "listed" in the Links list, might that have something to do with this? – SP2010 May 28 '14 at 13:01
1

We found that some libraries had their permissions removed. When we added the permissions back to those libraries, users can add new items to the list in question. So, the libraries must have been integrated into the list somehow.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.