2

I have been experiencing the oddest thing. I have a excel spreadsheet that has links within the document that are linked to a network drive. The links work perfectly in the excel spreadsheet until I upload the excel workbook to the SP13 document library. When I upload the workbook to the document library the URL is changed to the document library URL automatically. Has anyone experienced this issue before? Thanks for your help.

3

You may need to set "Update links on save" to false prior to adding your hyperlinks to the Excel spreadsheet.

In Excel 2010:
- uncheck "Update links on save" in Options > General > Web Options > Files tab

In Excel 2013:
- uncheck "Update links on save" in Options > Advanced > Web Options (under "General") > Files tab

After changing the Excel setting, re-create your hyperlinks in the spreadsheet, re-upload to SharePoint, and the links ought to be correct.

  • thank you so much for your response. I will try that now. Thank you! – SharePoint Lady May 28 '14 at 12:29
  • Hope it works for you! Let me know how it goes. – Phil Greer May 28 '14 at 15:33
  • Your steps were very helpful. The issue is still happening. Now I am not sure if this is a SharePoint issue. There are two other documents within the document library with embedded links to the network within the spreadsheet that are not experiencing the same issue. I unchecked "update links on save" and recreated the link. Therefore, if this were a SharePoint issue I am thinking the other two excel workbooks would not work either. Not sure what the issue maybe. However, I appreciate all of your help. Thanks! – SharePoint Lady May 28 '14 at 18:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.