I did the back up of a site collection using the following command in powershell.

Backup-SPSite –Identity https://Testsite.com/ -path C:\SiteBackup\Test.bak 

But when I open the site in browser I got the message

"We apologize for any inconvenience, but we've made the site read only while we're making some improvements."

and the site is set to read only mode.

5 Answers 5


I have came across many such scenarios, this happens mainly due to powershell command being interrupted. To resolve this you can use following powershell script

$admin = new-object Microsoft.SharePoint.Administration.SPSiteAdministration ("http://sharepoint/sites/sitecollection") $admin.ClearMaintenanceMode()

Once you execute this command it will make your site normal. Hope this helps.

  • Sudhir,I have already tried that,but no luck with that
    – Sai
    Commented May 27, 2014 at 19:48
  • ooh that's strange, are you running powershell as administrator when executing this commands, this has worked for me everytime. Do you know how site got locked to read only. What is the size of site? Commented May 27, 2014 at 19:51
  • not sure if this will help, but can you run another backup command on the same site, see if powershell is able to unlock it when the backup command is completed,,,#shooting in the dark Commented May 27, 2014 at 20:38
  • I think there is no enough disk space in dev server to complete the back up process
    – Sai
    Commented May 27, 2014 at 21:47
  • Hi Sudhir,I don’t have enough disk space in dev server to complete the back up process,that's why the site is still in read only mode. How to get back to normal mode
    – Sai
    Commented May 28, 2014 at 20:47

This error message can be thrown when the SQL Server space, the SQL server logs or the SharePoint logs are full.

If this is the case then check to see how much space free in SQL Server. Check the SQL Server log location. Clear out the SQL Server logs if need be. Check the SharePoint log location. Clear out the SharePoint logs if need be.

The SharePoint and/or SQL Server instance may need to be rolled to remove the read only flag.


How to Solve:


I came across an interesting issue recently where our production sites flag notification for every user "We apologize for any inconvenience".


This issues for regarding scheduled a backup task scheduler failed or interrupted for any resign,

I my case at the time of scheduler drive not have sufficient space. backup process was abnormally terminated.

This resulted all Sites being in Read only mode & the following message would show up when users browsed to the site.

We apologize for any inconvenience, but we’ve made the site read only while we’re making some improvements.

enter image description here

Go to “Site collection Quota & locks” in Central Admin & here is how the Status looks like. It is locked as “Read only” & all settings are grayed out weather you have administrator permission.

enter image description here

Here is more on this behavior & how to get out of this situation.

In SharePoint 2013, Microsoft introduced a property MaintenanceMode for SPSite object which indicates the site is undergoing a Maintenance & is read only. SPSite.MaintenanceMode flag can be set on a site for several reasons like content database is in read only state, or site collection is being upgraded, backed up or moved.

If a site gets into a state where the action that set this has terminated in a way where this is still set, we run into this situation.


The way to clear this flag notification is use the ClearMaintenanceMode method in SpSiteAdministration object. Here is how it can be done via SharePoint Management Shell.

Option Command 1:

#Run this command search site separately or run one by one all top level sites if we have multiple top level sites/ Web application.

# SiteName “http://m.com”.
$Admin = new-object Microsoft.SharePoint.Administration.SPSiteAdministration(‘SiteName’) 


Option Command 2:

Add-PSSnapin Microsoft.SharePoint.PowerShell -ErrorAction SilentlyContinue

#Clears all the maintenance modes for all Site Collections in the farm.

$webapp = Get-SPSite -Limit ALL

foreach ($site in $webApp){ 
    $Admin = new-object Microsoft.SharePoint.Administration.SPSiteAdministration($site.url)

two ways to unlock the site collection.

  • from central admin > application management > Configure quotas and locks > Select the Site collection from drop down...Now make sure the Radio Button "No Locked" is selected > hit ok
  • run the powershell to unlock it.

    Set-SPSite -Identity "" -LockState "Unlock"

  • 2
    Hi Waqas, I tried both of them but didn't work. I want to try the following commands but there in no root in Users folder PS C:\Users\root> $Admin = new-object Microsoft.SharePoint.Administration.SPS iteAdministration('root.toto.com') PS C:\Users\root> $Admin.ClearMaintenanceMode() PS C:\Users\root> $site.MaintenanceMode True
    – Sai
    Commented May 27, 2014 at 18:45
  • what is the status on the Central Admin, if you go above link, can you share the screen print?
    – Waqas Sarwar MVP
    Commented May 27, 2014 at 18:48

Did you fix this issue? Well I got into this mess when I ran a stsadm -o backup operation and I accidentally stopped the task in between.

Out of curiosity, I ran another stsadm backup operation and once it completed successfully, the site got unlocked.

Can someone confirm whether this will work if you lock the site via a diff powershell command?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.