0

I disconnected the server from the farm using SharePoint Config Wizard. Once that was finished I went into central admin and removed the server,

  1. On the SharePoint Central Administration Web site, in the System Settings section, click Manage servers in this farm.
  2. On the Servers in Farm page, locate the row that contains the name of the server that you want to remove, and then click Remove Server.

Remove a Server from the farm

The problem is that when I go into the Health Analyzer the now removed/disconnected/trashed server still shows up as having issues. How can I remove the server so that the errors will go away?

1

did you try to delete the error message from the resolve Problems & Solutions section? you can also try to re analyze it and see if that fix the problem.

If you just reanalyzed, I would try deleting the error so it no longer shows in this section and then manually kick off a run of this Health Analyzer Rule Definitions section and see if it still flags your removed server. It should also run on an hourly basis by default if you don't want to start it manually.

  • That seemed to do the trick. If I delete an issue will it actually recreate it if the issue still persists? – Grady D May 27 '14 at 13:45
  • It does recreate the issue even after deletion. On a side note you can also just edit the issue to remove the server if there are multiple servers having this issue in the farm. – Grady D May 27 '14 at 14:05
0
  • Edit the item into Failing Servers
  • Remove non existing server and
  • Put the replacing or existing one
  • Save and run the rule

This fix the issue for Me

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.