0

I am trying to do offline installation of Windows AppFabric on Windows Server 2012 using prerequisites installer as below but getting error.

Command

/AppFabric:C:\Users\myuser\Downloads\WindowsServerAppFabricSetup_x64

Error

Error: Custom file location is not accessible

I have confirmed that the file exists at the above location and that I am local administrator of that machine.

Here's some background on what I am doing. This machine doesn't have internet access as I tried to run prerequisites installer but it won't install.

So I downloaded all softwares required one by one and placed them in following location:

C:\Users\myuser\Downloads

After that I installed them by double clicking on the exes. Then I tried to install SharePoint and got error about AppFabric not installed or not properly not configured (something to that effect). Upon searching I came to know that you shouldn't install those softwares like that and instead should have used prerequisites installer to install them one by one as it also configures them.

Anyway I uninstalled AppFabric (which is another story as I had to try like 3, 4 times) and now I am trying to install it using prerequisites installer command line option but getting error.

Please help.

  • I'll add it as an answer instead :) – Robert Lindgren May 26 '14 at 6:41
  • That is right!! rename the end of the file from 64-enu to 65-enu impossible how they didn t find out before production. – Sokratis Laskaridis Apr 22 '18 at 10:02
1

Try to move the files to a "non-user-specific" place, like directly under c:\installation or so. It could be a problem of

Access Denied

| improve this answer | |
  • It turns out the error was not due to some access problem but because I didn't write file name extension in the end ".exe". So basically it should be like this /AppFabric:C:\Users\myuser\Downloads\WindowsServerAppFabricSetup_x64.exe – Frank Martin May 26 '14 at 9:47
0

In my case, I have downloaded the installer script from the Net, after removing one by one arguments from the script I found that there is an unknown character in AppFabric file name! typing the file name (including file extension) again and running the script solved the issue!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.