1

I have a list with a rich text column. When I add a hyperlink (using the toolbar) that points to a network location, SharePoint is stripping the URL from hyperlink. Hyperlinks with URLs to web sites are fine. I have tried both:

file://servename/folder name

and

\\Servername\folder name

I get the same result. The data is display as a link but there is no URL embedded in it. When I open the item to edit it, only the text remains

Edit: I can get it to work by just putting in the UNC directly as text, as long as it does not contain spaces. I tried to use %20 for spaces but the link includes the encoded chars in the path when you try to open the it.

SharePoint 2013

2

This is a known issue with the rich text editor. The hyperlinks will be removed unless they start with /, http, or https (might be a couple of others, but it's limited). Not a whole lot that can be done, you might consider storing the URLs in a separate column that doesn't go through the same rules.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.