3

I have a single-server SharePoint 2013 SP1 farm installed on a Windows Server 2012R2, with another 2012R2 server acting as a DC for farm-based accounts. I have another domain where users reside, running Windows Server 2003 and of 2003 functional level. SP farm has a User Profile service installed and a User Profile Sync service up and running.

I have created two AD connections, one for SharePoint internal domain and one for the other domain, both are limited by OUs that they synchronize, the limit was set at creation time. Now I cannot change any setting for these connections, they appear as non-interactive on "Manage Service Applications - User Profile Application - Configure synchronization connections" page. I can add another connection, but of course I cannot add another connection to the same AD instance. The manual says "right click on the connection, and select "Edit Connection Filters" (used this manual on TechNet), but all I can see is standard IE context menu of "Back" etc. The CA site is added to Trusted Sites.

I have discovered that I have a "bad" SP1 version of SharePoint 2013, so I went onward and installed a correct version of SP1, but this condition persists.

How can I modify AD connection settings, if the normal way is unavailable?

  • I just had this issue. Link was unclickable when RDP'd to the server but was fine when browsed to CA from my workstation (same user account in both instances). – user33088 Sep 3 '14 at 21:54
  • 1
    @Jay Change IE to compatibility view and add the SP site to trusted hosts list. Should do. – Vesper Sep 4 '14 at 5:06
10

The primary issue happened to be that IE used "normal" mode to open the CA site. To get the context menu for AD connection I had to force IE11 to use "compatibility mode" for CA site, this added the missing controls to the connections list.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.