1

Under site collection A I have created a Master file and need to move the file to site collection B. After I downloaded the Master file, in site collection B > site settings > Master pages and page layout, I uploaded the file, publish it and approved it. Then I apply the Master to site collection B.

Everything looks fine. However when I open site collection B with SP Designer 2013, click "Master Pages", I cannot see my new Master file. I can find the file via All Files > _catalogs > masterpage.

I am not comfortable with it. Did I miss some configuration or it is a software bug?

P.S. I need to write a deployment guide to IT supports which do not have Sharepoint experience. Hence I want to make sure I am working in the "best practice" way. Thank you.

2

When you upload a Master page, you need to choose "Publishing Master Page" content type. By doing so SharePoint Designer would able to list it out in "Master".

Step to upload:

  1. Site settings -> Master pages and page layouts
  2. Upload your master page, a property window will pop up. Pick "Publishing Master Page" as content type.

enter image description here

0

under which permission you are trying to access the site in the designer, I think you need administrator permission in order to view it.

Also from Central admin, make sure that SharePoint designer settings are enabled.

SharePoint Designer settings are controlled on a per-web application basis. There are these options

• If SharePoint Designer is enabled/disabled on a web application

• If Site Collection Administrators can detach pages from the site template

• If Site Collection Administrators can customize master pages and layout pages

• If Site Collection Administrators can see the URL of their web site

But i think /_catalogs/masterpage is correct location to get the master page.

also check this link

https://stackoverflow.com/questions/22294483/cannot-find-the-master-page-used-by-my-default-page

  • I am login with Farm admin and checked the 4 designer options are checked. I wonder there is some cache prevent designer show up new file. – Mark L May 23 '14 at 4:14
0

In case this helps anyone, I needed to make a minor change to the seattle master page and I don't have SharePoint Designer yet, so I mapped a network drive to the master page gallery, made a copy of seattle.html, called it seattle_custom.html, then edited it using Notepad++ and saved my changes. When I went back to the Design Manager, it showed the html file had been successfully converted to a master page, but it wouldn't show up as a choice under Site Master Page Settings until I published a major version of seattle_custom.html in the master page gallery in SharePoint.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.