5

I have a Visual Studio 2010 workflow for a SharePoint 2010 Server. It uses the default workflow action "SendEmail" to send an e-mail. Everything works out perfectly, but the sender of the e-mail is not the address I set in the "From" property of the "SendEmail" action ...

2 Answers 2

6

The From address of emails sent from workflow is fixed to the address set in Central Administration and can not be changed.

http://office.microsoft.com/en-us/sharepoint-designer-help/send-e-mail-in-a-workflow-HA010239042.aspx#BM9

The following options are not supported by the current version of the Send an Email action:

Specifying an address on the From line. E-mail messages sent by the workflow always show the e-mail address specified by the server administrator on the From line. Only the server administrator can change this, and it can only be changed for all notifications in the current Web application, not per workflow.

There is a project on Codeplex (spdactivities > Send Email Extended) that allows you to do this.

Alternatively you can send mail using .net's system.net.mail without these restrictions

4
  • Ok, thanks. Answers my question but leaves me wondering again, why the action has this property then ... ftw Microsoft ...
    – Hinek
    Commented Mar 9, 2011 at 13:31
  • 1
    Do you mean WTF or WTF? ;)
    – Ryan
    Commented Mar 9, 2011 at 13:32
  • Doh - FTW or WTF! urbandictionary.com/define.php?term=ftw
    – Ryan
    Commented Mar 10, 2011 at 12:13
  • Is this is same for Visual Studio WF? as the OP states he is using a VS workflow and not an SPD workflow...
    – Alex Clark
    Commented Mar 16, 2011 at 16:26
2

Is the sender of the email the 'From' address you specified in the Outgoing Email Settings in SharePoint? This should work - I have used the SendEmail action quite a few times with no issues.

1
  • Yes, it is the address specified in the Outgoing Email Settings. But it is NOT the address set in the "From" property of the workflow action.
    – Hinek
    Commented Mar 9, 2011 at 11:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.