1

I am configuring PowerView for my SharePoint enviornment. I was able to configure everything perfectly in a single server environment, however i am having challenges in getting PowerView to work on a multi server environment. Not sure what is going wrong here.

I have SQL Server 2012 SP1 and I am able to configure PowerPivot service application. When I uploaded an excel file with PowerView onto PowerPivot gallery, it just fails to render PowerView tab. The page errors out with following information-

Server Error in '/' Application.
--------------------------------------------------------------------------------
The resource cannot be found. 
Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly. 

Requested URL: /_layouts/ReportServer/AdHocReportDesigner.aspx

Looking at the ULS logs does not get me enough information. Below is the error message from logs in ULS.

    Application error when access /_layouts/15/RoamingAppsHandler.ashx, Error=The file '/_layouts/15/RoamingAppsHandler.ashx' does not exist.  
 at System.Web.UI.Util.CheckVirtualFileExists(VirtualPath virtualPath)    
 at System.Web.Compilation.BuildManager.GetVPathBuildResultInternal(VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile, Boolean throwIfNotFound, Boolean ensureIsUpToDate)    
 at System.Web.Compilation.BuildManager.GetVPathBuildResultWithNoAssert(HttpContext context, VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile, Boolean throwIfNotFound, Boolean ensureIsUpToDate)    
 at System.Web.Compilation.BuildManager.GetVPathBuildResult(HttpContext context, VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile, Boolean ensureIsUpToDate)    
 at System.Web.UI.SimpleHandlerFactory.System.Web.IHttpHandlerFactory2.GetHandler(HttpContext context, String requestType, VirtualPath virtualPath, String physicalPath)    
 at System.Web.HttpApplication.MaterializeHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()    
 at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

Any idea what could be going wrong here, I have installed Reporting Service in one of my App Servers.

0

Finally I was able to figure out why this was happening. I have to install Microsoft® SQL Server® 2012 SP1 Reporting Services Add-in for Microsoft® SharePoint® plugin on all my SharePoint servers (WFE + App) to get ASHX and other related files deployed onto _layouts directory.

When we install this plugin it deploys "ReportServer" folder under 15\Template\Layouts and this contains all the aspx, ashx files required to get PowerView builder working.

Hope this helps someone in need.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.