I have a Windows 8.1 machine that needs to edit workflows within SharePoint Designer (2013 SP1).

Whenever a workflow is clicked on one of two errors is received:

  1. Server side activities have been updated. You need to restart SharePoint Designer to use the updated version of activities.

  2. Windows Workflow Foundation, part of .Net Framework 3.0 must be installed to use this feature.

    Screenshot of Microsoft SharePoint Designer error message "Windows Workflow Foundation, part of .Net Framework 3.0, must be installed to use this feature.

Restarting does nothing to correct the errors.

Several blogs or support sites have recommended deleting temporary files which hasn't helped. I have reinstalled SharePoint Designer as well.

Another Windows 7 machine is also having the same issue with the same site.

It seems to be an issue with the site. The site is hosted on SharePoint Online.

  • Just wondering if you ever managed to fix this. One of our Windows 7 workstations has been suffering from the same issue for months, but I never managed to crack it. (Most likely eventually going to do a clean install of Windows) – Charles Grunwald Jan 18 '15 at 12:19
  • No, we stuck with using the workstations that didn't have the issue :( – jonoptew Jan 18 '15 at 20:34
  • Please check the below link for fixing this issue praveensharepointknowledgebase.wordpress.com/2017/01/10/… – praveen Jan 10 '17 at 6:45
  • I'm trying to solve this issue for 3 months now, for no avail. I usually stumble upon @praveen suggested solution. But it just doesn't work. – Luiz Angelo Aug 17 '17 at 18:57
  • Hi guys,did you found a solution? – Keshav Taurah Mar 7 '18 at 7:08

I followed directions on this website and was able to open my workflows again.

Basically, I cleared the following caches and restarted SPDesigner:

%APPDATA%\Microsoft\Web Server Extensions\Cache

%APPDATA%\Microsoft\SharePoint Designer\ProxyAssemblyCache


I also installed the Microsoft SharePoint Designer 2013 (KB3114721) update.

  • Just installing the update fixed it for me 🤙 Much headache avoided 🙌 – vanblart Sep 16 '20 at 12:23

Installing this update from Microsoft and then restarting fixed it for me. Download SharePoint Update


Yes, that did fix it for me. Thanks

Update for Microsoft SharePoint Designer 2013 (KB3114721) 64-Bit Edition


Installing the update above, ensuring that .NET Framework 3.0 was installed and then clearing the cache worked for me.

#Add Module Install-Module -Name DotNetVersionLister -Scope CurrentUser #-Force

#Check to see which/if .NET is installed and what version Get-STDotNetVersion

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.