1

when I try this in powershell:

Register-SPWorkflowService –SPSite "http://spserver2013" –WorkflowHostUri http://spserver2013:12291" –AllowOAuthHttp

I get this error:

    Register-SPWorkflowService : The remote server returned an error: (404) Not Found.
At line:1 char:1
+ Register-SPWorkflowService -SPSite "http://spserver2013" -WorkflowHostUri "http: ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~
    + CategoryInfo          : InvalidData: (Microsoft.Share...WorkflowService:
   RegisterSPWorkflowService) [Register-SPWorkflowService], WebException
    + FullyQualifiedErrorId : Microsoft.SharePoint.WorkflowServices.PowerShell
   .RegisterSPWorkflowService

here is what I got from Logs:

System.Net.WebException: The remote server returned an error: (404) Not Found.     at System.Net.WebClient.DownloadDataInternal(Uri address, WebRequest& request)     at System.Net.WebClient.DownloadData(Uri address)     at Microsoft.SharePoint.Administration.SPSecurityTokenServiceJsonMetadataClient.DownloadMetadata(Uri metadataEndpointUri)     at Microsoft.SharePoint.Administration.Claims.SPTrustedProviderBase.UpdateFromMetadataFeed(Boolean isFirstTime)     at Microsoft.SharePoint.Administration.Claims.SPTrustedProviderBase..ctor(SPPersistedObject parent, String name, String description, X509Certificate2 certificate, Uri metadataEndPoint, SPSecurityTokenServiceJsonMetadataDocument metadataDocument)     at Microsoft.SharePoint.Administration.Claims.SPTrustedProviderBase..ctor(SPPersistedObject parent, String name, String description, Uri metadataEndPoint)     at Microsoft.SharePoint.Administration.Claims.SPTrustedSecurityTokenService..ctor(SPPersistedObject parent, String name, String description, Uri metadataEndPoint)     at Microsoft.SharePoint.WorkflowServices.WorkflowServiceHelper.EnsureTrustedSecurityTokenService(Uri metadataEndpoint, Boolean allowHttp)     at Microsoft.SharePoint.WorkflowServices.WorkflowServerPairingContext.ConfigureOAuth(Boolean allowOAuthHttp)     at Microsoft.SharePoint.WorkflowServices.PowerShell.RegisterSPWorkflowService.InternalProcessRecord()     at Microsoft.SharePoint.PowerShell.SPCmdlet.ProcessRecord()

enter image description here

get-wffarm:

    FarmType                   : Workflow
WFFarmDBConnectionString   : Data Source=sqlserver2012;Initial
                             Catalog=WFManagementDB;Integrated
                             Security=True;Encrypt=False
RunAsAccount               : sp_workflow@XXXXXX
AdminGroup                 : BUILTIN\Administrators
Hosts                      : {Name: spserver2013.XXXXXXX.com, Configuration
                             State: HostConfigurationCompleted}
InstanceDBConnectionString : Data Source=sqlserver2012;Initial
                             Catalog=WFInstanceManagementDB;Integrated
                             Security=True;Asynchronous
                             Processing=True;Encrypt=False
ResourceDBConnectionString : Data Source=sqlserver2012;Initial
                             Catalog=WFResourceManagementDB;Integrated
                             Security=True;Asynchronous
                             Processing=True;Encrypt=False
HttpPort                   : 12291
HttpsPort                  : 12290
OutboundCertificate        : Thumbprint:
                             EF7820779415339B6EAE127A756677E265E6C7FB,
                             IsGenerated: True
Endpoints                  : {https://spserver2013.XXXXXX.com:12290/}
SslCertificate             : Thumbprint:
                             0DAF61EB086953AB8D07BFDB09F68724BDFF12FC,
                             IsGenerated: True
EncryptionCertificate      : Thumbprint:
                             0DAF61EB086953AB8D07BFDB09F68724BDFF12FC,
                             IsGenerated: True

I have sharepoint 2013 sp1 on windows server 2012 r2 updated

I've Uninstalled and Installed workflow manager several times, but the same result occurs.

what gives folks?

2

Install the CU2 update for workflow manager. It will fix the issue. http://min2dmax.wordpress.com/2014/06/05/register-spworkflowservice-the-remote-server-returned-an-error-404-not-found/

  • Yes , this helped me to get rid of this issue... – Esaki Dec 15 '16 at 7:18
0

I had the same problem with SharePoint 2013 Sp1. Used the following command with a -Force parameter:

Register-SPWorkflowService -SPSite "http://yoursite/" -WorkflowHostUri "http://yoursitecollection:port" -AllowOAuthHttp -Force

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.