1

I just noticed that the root of my Sharepoint Online website gives a 404 error. I have several subsites that work just fine, and I can still access all the pages of my site: the only problem is that '/' seems to point to nothing.

How do such a thing happen ? And how do I fix it ?

1

So to understand correctly:

When you are trying to access https://domain.sharepoint.com/, you are getting 404 error website not found? When you are trying to access https://domain.sharepoint.com/subodomain, you have no issues?

Before you got the error: have you tried to rename the site? Edit in Designer/VS? Are you being redirected anywhere? Is the site in the bin? Is it listed among site collections? Do you get the site via Powershell when you write get-sposite?

Can you verify what you have in Trusted Locations under Sharepoint Admin Centre?

  • Question 1 and 2, yes. I tried renaming the site, I did use Designer but not VS. I'm not being redirected. I don't have the rights to access the site collection view. But using the REST API, I can perform any action I want on the site with no problem whatsoever. I've made progresses, discovering that the file 'FormServerTemplates/Forms/template.dotx' has been modified and cannot be restituted to its default state. Could it be linked to the issue ? – user3387633 May 20 '14 at 8:51
  • I deleted these two files, they can't be restored for some reason. Didn't change anything. And I also don't have access to the Sharepoint Admin Centre. And to be more precise about the issue, I can access any page of the site at the root of the collection (eg: domain.sharepoint.com/_layouts/15/viewlsts.aspx), plus the subsites (eg: domain.sharepoint.com/subdomain), but while the '/' path should redirect me to 'SitePages/Accueil.aspx', it just displays '404' instead. – user3387633 May 20 '14 at 9:03
  • Alright that answered the question. The 'SitePages/Accueil.aspx' file does not exist. If I replace it with one from another site, then it stops bringing up 404 error and just shows a crash page. I can't restitute the default version for this file unfortunately... – user3387633 May 20 '14 at 9:11
  • I think that Microsoft is making backups so if you had some extremely important information there, you can request a restore. However, you will have to agree to restore a whole site collection from a given (recent) date, not just a subsite or .aspx file. – grisha May 21 '14 at 6:23
  • I'd gladly comply to these conditions... I don't even have anything really important there: the real problem is that my boss won't like the idea of paying the 300 euros it costs to ask Microsoft for such an intervention. – user3387633 May 21 '14 at 15:49
0

Probably someone deleted Home.aspx. That's kind of an index.html for a sharepoint site. Go to the following URL: https://<yourtenant>.sharepoint.com/sites/<yoursite>/_layouts/15/RecycleBin.aspx

Then restore the file from there.

New contributor
realMarkusSchmidt is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.