4

Here's the error which occurs while installing the binaries

No product configuration wizard yet! Just good old Windows Installer

2014/05/16 23:49:06:025::[1880] MSI(INFO): 'Action start 23:49:06: ArpWrite.'
2014/05/16 23:49:07:409::[1880] MSI(INFO): 'CustomAction ArpWrite returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)'
2014/05/16 23:49:07:409::[1880] MSI(INFO): 'Action ended 23:49:07: ArpWrite. Return value 3.'
[...]
2014/05/16 23:49:07:425::[1880] Error: Failed to install product:  D:\global\oserver.MSI ErrorCode: 1603(0x643). 
2014/05/16 23:49:07:425::[1880] Log level changed from: Standard to: Verbose
2014/05/16 23:49:07:425::[1880] Rolling back chain

I tried to install SharePoint 2013 on a shiny new Hyper-V VM (host OS is Windows 8.1).

This is what I tried already:

  • Using Windows Server 2012 (no R2, no update)
  • Using SharePoint Server 2013 (no SP1)
  • installing all windows udpates prior to sharepoint installation
  • any combination of these
  • installing office prior to sharepoint
  • installing visual studio prior to sharepoint
  • using a generation 1 or generation 2 type virtual machine
  • different license keys (enterprise and standard for sharepoint)
  • using 2, 4 or 6 virtual cpus
  • I made sure the .iso images I use match those on MSDN (SHA1 hashes match)
  • both online and offline installations

The problem is reproducible. I did manage to successfully install the binaries twice (out of like 50 times). Curious as I am I tried to revert to an earlier snapshot and reproduce the successful installation attempt. I failed twice. I believe there's a 'random' thing part of the equation.

I'm out of ideas.

  • Look out for event id on the internet. See if you see any thing in event logs – Sudhir Kesharwani May 16 '14 at 23:57
3

I got the same error Microsoft SharePoint Server 2013 encountered an error during setup,

enter image description here

In my case, the root cause was because of using only one processor core for my Hyper - V to install SharePoint that should be more than one so I followed the mentioned steps here to increase it , Hope this help you.

2

I was facing the same issue, after researching for almost one whole day I found all the failed solutions which you have mentioned here. Then I found the solution which worked, and is also very logical and safe. Here is the link to the blog post with details about the solution.

https://www.devfacto.com/insights/resolved-error-1603-installing-sharepoint

So to resolve this, we wrote the following PowerShell script (run as Administrator):

if(!(Test-Path HKLM:\SOFTWARE\Policies\Microsoft\Windows\Installer)){
New-Item -Path HKLM:\SOFTWARE\Policies\Microsoft\Windows\Installer | Out-Null
}
$regProps = Get-ItemProperty -Path HKLM:\SOFTWARE\Policies\Microsoft\Windows\Installer
if(! $regProps.logging){
New-ItemProperty -Path HKLM:\SOFTWARE\Policies\Microsoft\Windows\Installer -Name logging -Value voicewarmup -PropertyType String | Out-Null
}
if(! $regProps.debug){
New-ItemProperty -Path HKLM:\SOFTWARE\Policies\Microsoft\Windows\Installer -Name debug -Value 3 -PropertyType DWord | Out-Null
}
0

For those installing on a hardware server, check the Power Options in the server BIOS and change from Performance to Balanced. This was the fix for a similar reported issue when installing Office Web Apps, and it worked for our Sharepoint 2013 install after many, many frustrating hours.

-1

In my case, I installed updates and restarted the server then the problem solved

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.