1

I created a small SharePoint app for testing deployment of a simple list and content type. There is also a Remote Event Receiver to run some code when the app is installed. I'm using Visual Studio 2013. This is being deployed to an online SharePoint site on Office 365 but I'm not using Azure. The problem I'm running into is I get this error when I deploy:

The remote event receiver callout failed. There was no endpoint listening at //localhost:...... /Services/AppEventReceiver.svc that could accept the message. This is often caused by an incorrect address or SOAP action.

I've found many postings for this issue but they've all been for Azure or Visual Studio 2012, such as enabling remote debugging in VS 2012 or using the Azure Service Bus. As I did some looking around in my project, I came across a Remote Endpoints tab in the AppManifest.xml and it has no values in it. I experimented by putting in my site url and attaching /Services/AppEventReceiver.svc but that wasn't it. Does anyone know what I might be missing here or what I'm doing wrong?

Thanks in advance, Shaun

  • did u find any solution? then plz update this post for help. – user33006 Sep 19 '14 at 6:02
  • Not sure if you have found answer or not but what you need to do is for debugging RER create an Azure Service bus relay and copy and paste the end point(sb://---) into the Azure Connection string text box in Sharepoint tab of Office 365 project properties. – Pavan Josyula Oct 7 '15 at 3:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.