Reputation
1,735
Top tag
Next privilege 2,000 Rep.
Edit questions and answers
Badges
8 31 74
Impact
~377k people reached

Apr
20
awarded  Popular Question
Apr
19
awarded  Popular Question
Apr
7
awarded  Popular Question
Apr
6
awarded  Popular Question
Mar
25
awarded  Famous Question
Mar
21
awarded  Yearling
Mar
9
comment Announcement strips domain name from link
Okay, I undo my offense-taking. :) Thanks for answering.
Mar
8
awarded  Nice Question
Mar
5
comment TIFF files having black background in Image Library
I read your comment - you said there is no "easy" fix. How can you add your own "preview" thumbnail?
Mar
4
comment TIFF files having black background in Image Library
So how do you solve it?
Mar
4
comment Announcement strips domain name from link
Thanks for the advice about copy-paste. I thought what you had posted was an overwrite of the RTE function - I didn't realize you were posting the original code. I understood enough of it to know what I was pasting, although I admit I didn't study it completely. I might be an idiot, but not completely.
Mar
4
comment Announcement strips domain name from link
Sorry, I couldn't tell that you weren't suggesting for me to add it... It didn't seem to do anything so I removed it. So, this isn't really a solution, just useful information.
Mar
3
awarded  Popular Question
Mar
3
comment Announcement strips domain name from link
This has the advantage that the relative links are preserved in the actual announcement item, whilst the absolute url is inserted into the email message.
Mar
3
accepted Announcement strips domain name from link
Mar
3
comment Announcement strips domain name from link
This actually works! I can't believe it! And for the record, any richtext formatting IS retained after the replacement. This is the solution. I'll give you the reward, but I have to wait for 10 hours, says the site.
Mar
3
comment Announcement strips domain name from link
Sharepoint strips the domain. I know this from other posts and blog sites. Besides, if I create a link in an Announcements list that does NOT use any workflow at all, the domain is still stripped out. You can see it by opening the announcement in edit mode and going to check the link url - the url will be stripped. However, if you hover over the link, the browser will display the entire url - must be some javascript.
Mar
3
comment Announcement strips domain name from link
Everything is 2010 (I tagged my question that way, actually) - but this is not a bad idea. Maybe I can add something like this to my workflow that sends the email.
Mar
3
comment Announcement strips domain name from link
Also, if you type out the url, it doesn't get hyperlinked in the actual announcement on the portal.
Mar
3
comment Announcement strips domain name from link
In my case this is happening in an announcements list which gets sent to an email distribution list via workflow. I can't change it to plaintext - it has to be richtext.