307 reputation
211
bio website
location
age
visits member for 2 years, 3 months
seen Apr 7 at 20:50

Long time .NET developer recently returned to SharePoint after running a mile following a brief brush with 2003. Things seem to be a little better these days at least.


Mar
19
comment Poor performance in EnsureListItemsData method. What happens here?
No I never found the cause of this. We still see it intermittently and the location in the site collection varies. About the only suggestion I can make is to look for and eliminate any memory leaks in the page life cycle.
Jan
22
awarded  Yearling
Aug
13
awarded  Popular Question
Jul
17
comment 404 HTTP Module causes an authentication popup in Manage Content & Structure page
These 404 URLs are also called when loading the AssetPortalBrowser and UploadEx dialogs causing similar Access Denied errors and authentication popups.
Jul
12
awarded  Popular Question
Apr
30
awarded  Notable Question
Jan
11
comment SPLongOperation only starts at operation end
Curious, both the environments in question have the same editions installed i.e. SharePoint Foundation 2010, SharePoint Server 2010 Enterprise & Office Web Companions 2010 (as per the SKUs listed by 'get-spfarm | select Products'). The only difference is the dev environment has Project Server 2010 too, though I can't imagine that enables the SPLongOperation. Thanks for the info fallout, if I find anything further interesting I'll update here.
Jan
11
awarded  Critic
Jan
10
comment SPLongOperation only starts at operation end
Both are Server 2010 installs on Windows Server 2008. I can backup and restore both ways so I assume they are patched to the same version as well?
Jan
10
comment SPLongOperation only starts at operation end
Did you find a solution to this problem? I have the same behaviour where the panel only shows when processing ends. In my development environment the panel shows, the process takes a long time, and then the user is redirected. On our production environment the process takes a long time, then the panel shows and is immediately redirected, which I think is the problem you were having? Did you solve it?
Jan
9
comment FBA and the People Picker
As it was the IUSR account for me perhaps the anonymous account in IIS? One way to check if this is actually your issue would be to run SQL Profiler on the database server and see what is happening, I expect that is how I debugged it. If your not working with a public facing application then you could open up your membership database to basically everyone just to test if that fixes the issue and then at least you would know you were looking in the right place.
Jan
9
comment FBA and the People Picker
This was some time ago, however it would appear that giving the IUSR account read/write permissions on the membership database resolved the issue for me. If you have the exact same issue (ie. FBA works everywhere except the people picker in the SharePoint application) perhaps your IIS configuration is set to use a different account?
Jan
7
comment How to force programmatically create Thumbnail in Sharepoint 2010 FOUNDATION
One would assume this only works for images. If you are looking for an icon for PDF, PPT etc then use an image. If you are looking for a thumbnail preview of the contents of a PDF, PPT etc whilst definitely acheivable programmatically it would be a considerable undertaking.
Jan
7
comment How to force programmatically create Thumbnail in Sharepoint 2010 FOUNDATION
That's right Steve, if the image is larger than 640px wide, otherwise _W will just return the image. The thumbnails generated with _t are 160px wide.
Jan
7
answered How to force programmatically create Thumbnail in Sharepoint 2010 FOUNDATION
Oct
19
comment Poor performance in EnsureListItemsData method. What happens here?
No it isn't. That's just the top Google search result for the title of my question, which I kind of thought to do myself. But thanks anyway. Out with Reflector it is then.
Oct
18
asked Poor performance in EnsureListItemsData method. What happens here?
Oct
18
comment Why is central admin time different from server time?
Ah of course! For some reason I struggle to see Central Admin as a SharePoint site of its own managed using the same settings pages as any other SharePoint site. Cheers!
Oct
18
accepted Why is central admin time different from server time?
Oct
4
accepted Deleting a variation label