432 reputation
412
bio website
location
age
visits member for 3 years, 1 month
seen yesterday

Jan
10
comment Why web parts are loading sequentially?
That's just how it is now :) , but I haven't included it in the codesample because I thought it wasn't relevant. The user experience is quite good, except for the sequential load effect... Maybe the best solution is having the less expensive webparts with asyncron load and the most expensive with delayed load and trying not to have many of the expensives ones in a Page.
Jan
10
comment Why web parts are loading sequentially?
Ok, thank you. I would prefer a mix of the two solutions, but now at least I know I can't (until somebody tells me the opposite). The problem is that we have some calls that can last 10 seconds to retrieve the data, so maybe it is not a good solution having the page not available all this time. I also have detected that having the delayed load, webparts are loaded in order. That means that the first in page will be the first to load. It could be interesting in some scenarios (tabs perhaps?).
Jan
10
accepted Why web parts are loading sequentially?
Jan
10
comment Why web parts are loading sequentially?
This webparts are custom and they not have asynchronous settings. The timer is needed in order to start a postback once the page is loaded, and after its first tick it is removed. It is not used to update the contents periodically.
Jan
10
comment Why web parts are loading sequentially?
So, either I have asyncronous loads while the page is rendered and it is not available until all them end, or I have deleayed loads but sequentially. Am I wrong?
Jan
10
comment Why web parts are loading sequentially?
No, I don't use them yet. It is one of to-do things we have planned. But will it work with update panels? I tried to call Load_Data methods within a thread and it resulted that my webparts didn't get the postback result properly. Besides, this methods are not available in site collection's recursive search.
Jan
9
asked Why web parts are loading sequentially?
Jan
9
comment CAML: Possible to query non existing field?
Have you tried to add Nullable="True" at FielRef?
Dec
19
comment Import&Export Sharepoint Lists / Deploy this with VS2010
Check this, it could help (not tested): technet.microsoft.com/en-us/library/ee428301.aspx
Nov
18
accepted IFilterProvider Interface example error
Nov
17
awarded  Commentator
Nov
17
accepted How to create multiple different connections from a producer web part?
Nov
17
answered How to create multiple different connections from a producer web part?
Nov
17
comment How to create multiple different connections from a producer web part?
Yes it works, but I think it is not possible to create more than one connection between two webparts
Oct
28
comment Import&Export Sharepoint Lists / Deploy this with VS2010
I don't know another way to do it with more than one list at a time. Sorry...
Oct
28
revised Import&Export Sharepoint Lists / Deploy this with VS2010
added 13 characters in body
Oct
28
comment IFilterProvider Interface example error
The other Web Part is not in another Page, so I don't know why it is happening this. Thanks for the link about IFilterProvider Interface. It is not what I was expecting but I could have another use for this.
Oct
27
asked IFilterProvider Interface example error
Oct
26
awarded  Tumbleweed
Oct
25
comment Filtered SharePoint List for Export to Excel
Same problem, and I also need to print them directly...