201 reputation
722
bio website
location Argentina
age 26
visits member for 3 years, 2 months
seen Jul 13 at 16:37

Nov
14
comment How to know which users viewed which documents in provider-hosted Sharepoint 2013 App
According to this msdn.microsoft.com/en-us/library/jj245254.aspx SP.ChangeQuery API is JS. I'm looking for something that can be used from server side (I'm using a high-trust STS app so server side code is available, just not full trust code). 2) and 3) doesn't seem to be a viable solution since I need to provide this for different companies, with different environments and I need something that can be all packed-up in a provider-hosted SP app. 3) is what we did on SP2010 full-trust solution. Isn't a way to query the SP.ChangeQuery via CSOM?
Nov
13
asked How to know which users viewed which documents in provider-hosted Sharepoint 2013 App
Nov
13
accepted Error occurred in deployment step 'Uninstall app for SharePoint': The System Account cannot perform this action
Oct
31
answered Error occurred in deployment step 'Uninstall app for SharePoint': The System Account cannot perform this action
Oct
31
revised Error occurred in deployment step 'Uninstall app for SharePoint': The System Account cannot perform this action
added 116 characters in body
Oct
31
asked Error occurred in deployment step 'Uninstall app for SharePoint': The System Account cannot perform this action
Oct
25
comment Getting 401/403 in High Trust App for Sharepoint 2013
@aliSharepoint Ok, I finally got it working. I had to turn of the HTTPS requirement for OAuth during development (msdn.microsoft.com/en-us/library/fp179901.aspx) because I'm using a self-signed test certificate. I don't know why I was getting 401, but now it works and it's all I care. Thank you again for all your answers.
Oct
25
comment Getting 401/403 in High Trust App for Sharepoint 2013
@aliSharepoint Unfortunately I've already seen that post and double-checked everything it says. I've tried all the things I've found in blog posts, articles, etc. about High Trust Apps in Sharepoint 2013 and how to get rid of the 401 error. I'm pretty sure it's something about the configuration of Sharepoint 2013 in the Cloudshare environment. But I don't know what it is.
Oct
23
comment Getting 401/403 in High Trust App for Sharepoint 2013
It's not the loopback thing, I've already tried that. The site is accessible from a client machine. I still haven't found the issue. I gave you the bounty cause you were really helpful with your long answer. But still dealing with this problem. I'm using NTLM, I have synchronized the profiles, I've done the New-SPTrustedSecurityTokenIssuer several times.... This is frustrating.
Oct
20
accepted Getting 401/403 in High Trust App for Sharepoint 2013
Oct
17
comment Getting 401/403 in High Trust App for Sharepoint 2013
Thanks again for the answer. I'll check everything you pointed out but want to make clear that there are no 2 servers. The same place where the app resides is where Sharepoint is and where I develop using VS2012. It's a Cloudshare environment.
Oct
16
comment Getting 401/403 in High Trust App for Sharepoint 2013
Thanks for the long reply. Unfortunately, I've already tried all of that. Tried disabling HTTPS, didn't work. Yes, I'm using the default code that comes with the provider-hosted app for Sharepoint 2013 which indeed uses the TokenHelper class. Regarding permissions, I'm not trying to do anything but the default code which I think only authenticates the user and nothing more. And regarding the ID, VS2012 doesn't update the IssuerId, just the ClientId. The IssuerId corresponds with the one get from Get-SPTrustedSecurityTokenIssuer, and yes, both are lowercase. This is driving me crazy.
Oct
16
revised Getting 401/403 in High Trust App for Sharepoint 2013
added 366 characters in body
Oct
15
comment Getting 401/403 in High Trust App for Sharepoint 2013
@billfredtom It was set to "Trusted sites". I move it to "Local intranet", nothing happened. Same error.
Oct
11
revised Getting 401/403 in High Trust App for Sharepoint 2013
Added ULS log entries
Oct
10
asked Getting 401/403 in High Trust App for Sharepoint 2013
Oct
10
accepted Feature with Id 'guid' is not installed in this farm, and cannot be added to this scope
Oct
2
awarded  Notable Question
Sep
26
comment Feature with Id 'guid' is not installed in this farm, and cannot be added to this scope
@MarcoScheel Yes, yes it is.
Sep
26
comment Getting “(401) Unauthorized” error while trying to run Provider-Hosted app in SharePoint 2013
Have you been able to fix this issue?