677 reputation
318
bio website
location Glasgow, United Kingdom
age
visits member for 4 years, 5 months
seen 2 days ago

Feb
17
comment PreSaveAction on a ListInstance with a custom ContentType
I think there was a JS issue, thanks it does work even though VS doesnt like it.
Feb
17
comment PreSaveAction on a ListInstance with a custom ContentType
Doesn't look like its working with my version of SP2013/VS2012. JSLink works fine in the CustomField but not in the form tag in schema.xml.
Feb
17
comment PreSaveAction on a ListInstance with a custom ContentType
I'd gone down the route of using JSLink on the field itself to validate it, I didnt know it could be used on the form itself.
Feb
17
asked PreSaveAction on a ListInstance with a custom ContentType
Feb
14
comment Why does SPList.GetItems(string fields[]) return more fields than specified?
is there a typo on that code? shouldnt it be an array of strings you're passing in instead of just comma separated values? SPListItemCollection items = list.GetItems(new string[]{"UniqueId", "Name"});
Feb
8
awarded  Yearling
Feb
6
revised When creating a web part project, is it true that we have to add it as safe control?
added 333 characters in body
Feb
6
answered When creating a web part project, is it true that we have to add it as safe control?
Jan
30
comment ListDefinition and ListInstance failures with custom content type
I think it was to do with spaces in names - essentially I removed my ListDefinition and ListInstance, renamed my SiteColumns and ContentType Fields with no spaces and recreated my ListDefinition and ListInstance, it all deploys nicely now.
Jan
30
accepted ListDefinition and ListInstance failures with custom content type
Jan
30
asked ListDefinition and ListInstance failures with custom content type
Jan
20
accepted Custom Workflow Feature not available in Site Features or Site Collection Features
Jan
20
comment Custom Workflow Feature not available in Site Features or Site Collection Features
yeah, I found it that way and enabled it using the guid in Powershell with the Enable-SPFeature command.
Jan
17
comment Custom Workflow Feature not available in Site Features or Site Collection Features
if it is - its not intentional.
Jan
17
comment Custom Workflow Feature not available in Site Features or Site Collection Features
doesnt clicking Deploy Solution from Central Administration install the feature? anyway Get-SPFeature shows the feature as being in the Web Application already. Using Enable-SPFeature made my workflows available but I need to figure out why the feature isnt in Site Collection Features
Jan
17
revised Custom Workflow Feature not available in Site Features or Site Collection Features
added 74 characters in body; edited tags
Jan
17
asked Custom Workflow Feature not available in Site Features or Site Collection Features
Jan
16
comment Controlling which feature a project element is added to
I know I can move them, but I'd have preferred to be able to specify them at creation time.
Jan
16
comment Controlling which feature a project element is added to
Thanks, the Mavention product doesn't work in VS 2012 but its a useful insight anyway.
Jan
16
accepted Controlling which feature a project element is added to