Tag Info

New answers tagged

0

The reason for this is that everything after # is picked up and executed using ajax/async. The part between ? and # has to remain the same for ajax to work. For the page itself it will disregard the original query as the k parameter after the hash takes precedense. So, can you strip it? Sure, if you override the script on the page...but the cost is that ...


0

Since MyCustomProperty="Something*" matched your document your managed property contains parts of your string but it doesn't equal your string. Did you try using :? Have you tried using wildcard with more search terms, i.e. MyCustomProperty="Something is*" or MyCustomProperty="Something is wrong*"? Is your query language and detected document language the ...


3

The real answer here is to create a result source where you for "Type" choose "People Search Results". You don't need to add ContentClass=urn:content-class:SPSPeople For example: {?({searchTerms})} {?OR (({searchTerms}) spcontenttype:contact)} will give people + results of contenttype=Contact When testing this in the query wizard it will append ...


0

Here is a snippet of the code I used using Microsoft.SharePoint; using System; using System.Collections.Generic; using System.Linq; using System.Text; using System.Threading.Tasks; using System.Web.UI.WebControls.WebParts; using Microsoft.Office.Server.Search; using Microsoft.Office.Server.Search.WebControls; private static void SetupSearch( SPSite ...


1

This is possible also in SharePoint OnLine. These are the steps that you have to do: (Go to) Sharepoint Admin -> User Profiles -> Manage User Properties -> New Property Here you have to choiche from some option. For sure you will need to make the property indexed Then go to Search -> Manage Search Schema -> New Managed Properties Here you have to ...


1

Check the result sources: People: {?{searchTerms} ContentClass=urn:content-class:SPSPeople} Local Content: {?{searchTerms} -ContentClass=urn:content-class:SPSPeople} For local the minus in front of the content class excludes the people results. For people the contentclass excludes your list. Create a copy of the people result, add your custom list ...


0

Use the Web Part Manager class, either SPWebPartManager or SPLimitedWebPartManager. There are a ton of blog posts that explain how to do this in PowerShell and as part of Feature Deployment.


0

I found a solution I've added kquery.TrimDuplicates = false; to the KQL, which means that the query will not filter out "duplicate" results.


0

I haven't spent much time on "Public Search" but thought I'd give it a try. I just checked my unpublished public site and it does not do this. I can search for all pages. I also checked a demo site and the behavior is correct as well. So, is it possible that you changed the Search Results.aspx page? If so can you revert it to the original and see if it is ...


0

May be you need to check your result source for the search. Currently the scope for the same might be limited to Blogs only.


1

I tried as told by Sane.Amit. But still i am getting the same result. Because it is already trimmed in the display template. So i updated the display template Item_CommonItem_Body. I replaced the below portion var titleHtml = String.format('<a clicktype="{0}" id="{1}" href="{2}" class="ms-srch-item-link" title="{3}" onfocus="{4}" ...


0

I had to look and see how I did this. (Not saying it's the right way, but it works.) I created a Queryable Managed Property called BCSEntityName and mapped it to the Business Data crawled property EntityName. In my case the entity name returns "Customers". (OH, and all of my BCS Managed Properties are in the SSA not the Site Collection, BCS Properties ...


0

I would dissect your query to determine the issue. Pare it down to a simple query. Remove the sorting, for example. Then watch the ULS Logs while the query executes. The SORTING processing has changed in 2013 and may be the root of your problem. There should be an error in ULS logs that tells you what is going wrong.


0

Create a new Display Template for that content type so that you can add the full HTML of the field in the result. You could also create a hoverpanel for the Content type to display the HTML, it's up to you. Create a Managed Property for the field with the HTML, if it doesn't exist. Copy an existing Display Template and add your Managed Property to it. ...


1

Try the following. Set "Which source should results match?" to "All Sources". Under "Show more conditions", select ContentSource contains any of (Your Content Source Name). Also ensure your display template is selected at the bottom.


0

Below function is working . you can put either in master page or in .js file that is reference in master page. $(function () { var theSearchBox = $('ctl00_PlaceHolderSearchArea_ctl00_S3031AEBA_InputKeywords'); var ctl00_PlaceHolderSearchArea_ctl00_ctl04 = '0'; var preferredSearchText = "Enter Search Term"; ...


0

The enableOptimisticTitleOverride no longer exists in SP2013. This problem has been fixed in the October CU. You can read more here in this long thread. http://social.msdn.microsoft.com/Forums/en-US/d2b79edd-1a77-49ee-b480-cba43edee761/search-returns-incorrect-document-title-under-sharepoint-2013?forum=sharepointsearch


0

For SharePoint 2010 this problem can be fixed by setting the value of EnableOptimisticTitleOverride to 0 in the registry key [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office Server\14.0\Search\Global\Gathering Manager] This does not work for SP 2013. You can try by creating a new managed property and map TermTile and Title crawled properties. As per this ...


1

First of you should use SPContentType and not ContentType. For some reason ContentType seems a bit unstable but the "special" SPContentType always works. In addition to the suggestions by @Sane.Amit you can edit the search result web part and change the sort order drop down values, then uncheck it again as explained in my post: ...


0

The title of each search result is governed by the css associated with .ms-srch-ellipsis class. .ms-srch-ellipsis { white-space: nowrap; overflow: hidden; text-overflow: ellipsis; } Due to the text-overflow property being set to ellipsis you are seeing the title followed by a few dots. I think it is better to keep it this way around. And in ...



Top 50 recent answers are included