New answers tagged

0

You could add a redirect script (what ever your code of choice is) on load to redirect them to a different page by adding a script editor part to the page. I know it's not an an iron clad solution but just another deterrent.


1

No, if they can read the metadata about an Item (the Document is contained within the Item), they'll be able to open the document itself. But in this case, I'd suggest providing Full Read access on the User Policy of the Web Application.


0

This scenario is not good fit for the SharePoint. You have to use the 3rd party software to manage the password. In past we used the PAR tool from Dell (old Quest). Reason why SharePoint is not fit. Once user get the password, then User dont need to come back and get it. as SharePoint will not change the password. You have to manually change the Password ...


0

If you really dont want Limited access feature in your site, deactivate the Limited-access user permission lockdown mode feature. And check if you still face that issue.


0

Just an idea, you could create lists in order to achieve that. For example, you create 2 lists, A and B, grant permissions to some users to the list A and some to the list B. In the manager's case, you grant permissions to both lists, the items in those lists are the username/password. Also, it is nice that you can grant users read-only access so only users ...


0

Both options require you to possible break interference and/or create custom permission groups. Option 1. Document sets might be a viable solution for you. Here You may also want to create an item for each student. You can then restrict their rights to read only and create so they can only see their work. Option 2. might be to run a 2010 workflow that ...


0

You could do this by creating a custom permission level for the Students, and granting them only Add, View and Open permissions, and not Edit or Delete. Here is a list of all the permissions available. An easy way to do it would be by copying the "Contributor" permission level, then going in and removing the Edit Item and Delete Item permissions on your ...


0

Out of the box you can use enable Item Level Permission. From UI this is available only for Custom Lists. But you can enable the same on libraries using PowerShell. This will not fully satisfy your requirements of not allowing delete. Your best option is using Workflow. Another option is to use Event Receivers.


0

I think what I'm trying to achieve is simply not possible in Microsoft Sharepoint. Instead I've created 2 differents custom lists with differents permissions, then created a workflow that copy every item submitted by a user into one of these lists, depending on fields values.


1

Check permissions only checks the permissions of the current object that you invoked Check permissions on. For example: If you do Check Permissions on the site, it will detail how a user has site level access only. If you do it on a document library, it will detail how the user has access to the document library only. If you do it on a file, it will ...


1

REST is only going to give the users results to what they have access to (I'm surprised the lookup column actually works as they currently don't have access to the data). If you don't give them permission, they won't see it. Set unique permissions on the list so everyone has read access, except for a group that will be responsible for maintaining the data. ...


2

To my understanding, when you enable rating feature in a list/library, Rating (0-5) column, a Number of Ratings column is also added to the list. Hence these columns will be associated with each list item. Technically, when a user (consider the user has contribute access) gives a rating to a document, the columns related to rating feature gets updated, which ...


0

Go to Read Permission level in Site Permission and check for Read permission if there is an option for rating enabled..If it is unchecked, check it and then try. Read permission ideally have the permission to rate


0

You should create a SharePoint Group that don't have Manage List permission. Now add all users who can't approve the items into that group. Now go and remove the users from the current groups.


1

Create a group add the user with edit permission. You can give the unique permission level to that library or document.


2

May be your email id is given in Access request settings. Hence all the access request are coming to your mail. To change that: Go to Site Settings. Under Users and Permissions, click Site Permissions. On the Permissions tab, click Access Request Settings. In the Access Request Settings dialog box, select the check box next to Allow access ...


1

Sure, you can always brake the inheritance of a folder and assign unique permissions. See my other answer to a similar question: How to make a file read only in a folder?


3

You click the little ... ellipsis menu on the folder and click Share. From that pop up, click Shared With and from there click Advanced. On the corresponding screen, click the Stop Inheriting Permissions button to break permissions inheritance from the parent (the library). Set permissions as desired.


2

If you want to display a content to the user only with 'Full Control' permission level use the below snippet <Sharepoint:SPSecurityTrimmedControl runat="server" PermissionsString="FullMask"> <div id="s4-ribbonrow" > </div> </Sharepoint:SPSecurityTrimmedControl> Different base permissions EmptyMask : Has no permissions on the Web ...


0

So, I managed to find a solution for my question. Bellow is Powershell script code: Add-PSSnapin microsoft.sharepoint.powershell -ErrorAction SilentlyContinue #Variable for Web URL $WebURL ="#" #get Web object $Web = Get-SPWeb $WebURL #Get Lists with Unique permissions - Exclude Hidden lists $ListColl = $web.lists | Where-Object { ($_.hidden -eq $...


0

This is expected behavior since you removed edit items role from your custom permission level. Since you have metadata attached to your library, when uploading, it will redirect the user to the EditForm.aspx page so the user can supply the necessary metadata fields. Since you removed this role, you get the error screen. Some ways to resolve this: Give the ...


2

Try this #Variable for Web URL $WebURL ="Your URL " # Varibale to hold document count $count = 0 #get Web object $Web = Get-SPWeb $WebURL if ( ($web.HasUniqueRoleAssignments) -and ($web.IsRootWeb -eq $false ) ) { $web.ResetRoleInheritance() Write-host "Broken Inheritance Reset on web:" $web.URL } #Get Lists with Unique permissions - Exclude Hidden ...


0

For folders try the following: $folders = $list.Folders if ($folders.Count -gt 0) { foreach ($folder in $folders) { if ($folder.HasUniqueRoleAssignments -eq $True) { $folder.ResetRoleInheritance() $folder.update() } } } For list items, try the following: $list_items = $list.Items if ($...


2

In SharePoint, when we upload a document to a library, the document will be uploaded to the library first and then it will pop up the document properties form for us to fill in the values. However, only a user who has edit items permission on the library can edit the document properties, so the form popped up for filling after uploading the document will ...


1

Because inheritance is disabled, meaning it will not inherit permission changes in the parent. Permissions are either inherited from the parent or broken. If inherited, any changes you make to the parent trickle down. If broken, changes to the parent are not reflected in the object with broken permission. The groups created in the root will be available ...


1

It's because you have break the inheritance. You can set individual permission for that group/user using Grant Permissions button in ribbon. Reference: https://technet.microsoft.com/en-us/library/jj219771.aspx https://support.office.com/en-us/article/Edit-permissions-for-a-list-library-or-survey-02D770F3-59EB-4910-A608-5F84CC297782?ui=en-US&rs=en-US&...


2

If I understand your question properly then, If you click Delete Unique permissions, then all the permissions you've set uniquely will be deleted. After breaking the inheritance, if you want to remove the groups then select the names of the groups/users and click Remove User permissions. The group/users (you delete here) will not be deleted but their ...


2

As @spguy mentioned, having separate document libraries can also help. However, if that is not an option, you can consider using folders to limit the fine grained permissions.


2

Are you limited to a single document library? Depending on what kind of content you are storing, is there any way to split them up and have multiple libraries? Are the 2000 documents that are submitted each year all of the same type of document that they cannot be separated? If you can split any of the documents up into active and archived documents, then ...


0

This is just an option. Check whether the Content editor webpart is placed inside the div for which contenteditable attribute is set to false. In that case make it true. <div contenteditable="true"> ---------- </div>


0

You need to have site collection administrator permission to perform this action.


0

Thanks to @Hardik I found the solution was to cancel check out and publish files. I just discovered the little arrow in a green square on each script file. These files were checked out and I cancelled the check out and published them. Thanks to everybody for help.


0

Try change the permission level of those users and add Manage Lists list permission. OR Typically the Style Resources Reader group has restricted read to the root style library. This group contains all authenticated users by default. First check to see if this group exists on the library and does have the all authenticated users in it. Second, check to ...


1

when creating a group in sharepoint, there is an option for specifying whether or not outside users can see the membership of the group. My guess is that even if she is a member of the owning group, she can't see the group(s) membership because she is not the direct group owner and the option to not show members is selected. Try editing the group and ...


0

I believe the information required is on consultantpoint's wordpress site. I have made one correction and added the binary column for easier reference. | Permission Name | Hex (base 16) | Binary | Decimal | |------------------------------|--------------------|------------...


0

You can enable Anonymous Access by going to Application Management in Central Administration, Highlight the WebApp where you want to enable Anonymous Authentication, Click on Authentication Providers, Click on the Zone where you want to enable Anonymous Access, then Check Enable Anonymous Access, Save. Go to your Web Application and the top level of the ...


0

Finally i did it. Even If you enable anonymous access to your Lists/Libraries, You still need deactivate "Limited-access user permission lockdown mode" Site collection feature to access list or library. [When this feature is enabled, permissions for users in the "limited access" permissions level (such as Anonymous Users) are reduced, preventing access to ...


0

views are pages.. you can break page permission and grant special permission to it.


1

Views cannot have security applied to them. They can have audiences. There is a difference in that you are not preventing access, but directing users to relevant information. As a point of note, search results of the list will return all results.


1

You can set permission on the list level easily from the list settings page. navigate to the that page and under permission, you will have to break the inheritance and grant these people (direct adding of each of these individuals a read only access). Once you do that, all the list views will inherit the permissions from the list


1

In OOB SharePoint, any user with read access can navigate to any views and we don’t have any permission which can be applied on the list view. Please refer the workaround for the same in below given link. How to set View level permission for a List/Library in SharePoint


0

The answer is no on SP 2013 and I don't recall this feature existed on SP 2010 or 2007.


1

Please try to give "View Item" permission on your Document Library anonymous access via Library Permissions. Kindly check below image for your reference After doing this your documents have at least viewitem Permission on the document library so it will not ask for credentials for anonymous users.


1

If you are using managed navigation instead of structural make sure that the Navigation Node Type is a Simple Link or Header, the Term driven menu items are not visible to users with only read permissions. You can find more info about it here: http://sharepoint.handsontek.net/2016/05/12/metadata-navigation-is-not-visible-to-users-with-read-permissions/


2

Please check the full URL. The URL she is getting is the url of the library or the document. If it is document, probably document is having unique permission and thats why she is getting access denied. Try to check the permission of the document.


0

If your Top navigation has the link of subistes, chack whether the user has access to the subsite. Else if the links in the top navigation are just pages, check whether the user have permission for those page at the item level. Similarly, check wehther the users have access in the list level and in the list item level. If everything is fine, check whether ...


0

You can use Audience Targeting to show and hide web parts based on rules-based audiences(Global Audience), SharePoint groups, and distribution-list memberships Note: this is not the same as security trimming, however, it may server your requirement. Check this tutorial on how to do it step by step


0

You are updating the list item with read permission using below code which is definitely not going to work. this.listItem.set_item("ReviewStatus", "Requested"); this.listItem.update(); You can not update a listitem without having permissions on it. Running with Elevated privileges is the solution for your problem (Server). Apart from that i don't think ...


0

Client-side, the only idea I have is to create an independent list, using the javascript to add an item to that list containing the ID of the original item. Then run a workflow on the new list that uses an impersonation step to set the ReviewStatus field in the item with matching ID.


0

If you have broken permission inheritance and added item level permissions, then the group assigned to it will have access over the item even if you add new users to that group. Access is assigned to the group and not directly to user. Hence system will always check for that group. In your case User 1, User 2, User 3 and User 4 will be able to access that ...



Top 50 recent answers are included