Tag Info

New answers tagged

0

So... this had nothing to do with SharePoint apparently, as other users with Edit permissions WERE able to add web parts to the (visible) web part zones. We're guessing that out test user has some sort of IE policy setup that is different to regular users. So thanks to all for their help!


1

The changes can be made in site definition files. If the site created by you is using custom site template(You have created template) you can set it in the onet.xml file of the Site definition. In the onet.xml, refer the module in the configuration and define the module int he following way <Modules> <Module Name="Default" ...


2

Yes this is sharepoint OOTB error.. No solution for this If you want all users to have search enabled you can break permission and give them contribute permision at list level. Enable the show ribbon ->Always true


1

Since you have edited the page layout it de links from the content database, in order to roll back you have to use "Reset to Site definition" on ECB context menu of the layout. This is roll back your changes and it refers from the content database.


0

You can set permissions directly for your page layout within SharePoint Designer, but it's no a solution for you. (SharePoint Designer -> Page Layouts -> Permissions -> Stop Inheriting) You have to give 1. full control 2. Contribute 3. Designers Group Permissions in order to be able to work on webparts


0

You can choose from several sets of APIs to add/upload publishing page layout. Below is demonstrated how to add/upload publishing page layout via CSOM in PowerShell. Option 1 [System.Reflection.Assembly]::LoadWithPartialName("Microsoft.SharePoint.Client") [System.Reflection.Assembly]::LoadWithPartialName("Microsoft.SharePoint.Client.Runtime") Function ...


0

Try using this way: <%= SPUtility.GetLocalizedString("$Resources:MyTitle", "MeResourceFile", Thread.CurrentThread.CurrentUICulture.LCID); %> Take a look at this similar thread: How to use resrouce file inside page layout? Or Access resource file from page layout


1

You can update the associated content type by this indirect route. Suppose you have a content type name $contentTypeName, a web $web, and the list item of your page layout, $item. $item.Properties["PublishingAssociatedContentType"] = ";#" + $contentTypeName + ";#" + $web.AvailableContentTypes[$contentTypeName].Id.ToString() + ";#" $item.Update() ...


0

You can use Page.Controls for getting the control in Server Side. From your update I think below approach will work Create a Custom List to capture fields to Hide Now using Browser Tool find the element id and store it in the configuration list Now you need to take a decision whether to user Client Side or Serve Side If client side - Then use a Script ...


3

Option 1 How to add/upload publishing page layout via CSOM in PowerShell: [System.Reflection.Assembly]::LoadWithPartialName("Microsoft.SharePoint.Client") [System.Reflection.Assembly]::LoadWithPartialName("Microsoft.SharePoint.Client.Runtime") Function Get-ClientContext([string]$Url,[string]$UserName,[string]$Password) { $SecurePassword = $Password | ...


0

I think, there is no problem using your suggested approach. That can be useful when you are working on some static kind of stuffs. I usually prefer this kind of approach, when static content is there. Thing you need to remember is that in case you are upgrading your SharePoint with cumulative update, there might be a chance that that wiki page will get ...


0

I searched for you query on Google and found a link to the code-project site pointing on the same problem as yours. you will first need to import the Microsoft.SharePoint.Publishing.dll into power-shell and then follow the steps provided in this link


1

Once I had the same issue with my SharePoint 2013 sub site. So I had to set the theme again, that way it helped me. I know it is weird issue but saved my day. You should try that too. The only thing problematic here is the theme CSS file. Don't know why that CSS file is not being found. Hope this helps!


0

Thanks Rodirgo, your suggestion helped. and in the mean time I get another workaround: http://community.office365.com/en-us/f/154/t/229652.aspx this link also provide solution.


1

This message will show when we edit the properties of a page no matter which library / wikis we upload it to, it seems to be by design. If you have any webpart on the page, once you click on it, it will give you control to perform maintenance on the webpart i.e. Close, Reset. Delete etc. To remove that i think you need to Customized the EditForm.aspx.


2

If your list/library has multiple content types associated with it, the drop down will appear. If there are other content types that are not being used, remove them from the list and they'll go away. Otherwise, you'll need some script or css to remove/hide it.



Top 50 recent answers are included