Tag Info

New answers tagged

0

You're code sample looks 100% correct. Ensure you have PublishingWebControls registered. <%@ Register TagPrefix="PublishingWebControls" Namespace="Microsoft.SharePoint.Publishing.WebControls" Assembly="Microsoft.SharePoint.Publishing, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" %> Also verify that Page Layout file is checked ...


0

You can make the control readonly or completely hide it with the help of jQuery.. Following should help: <script type="text/javascript" src="[YOURPATHTOPROTOTYPE]/prototype.js"></script> <script type="text/javascript"> function SetTextFieldReadOnly(name) { var inputs = $$('input[title="' + name + '"]'); if (null != inputs && ...


0

It could possibly be that you've added a custom 'subsites' heading to the menu; then, collected the subsites under that custom heading and indented them by using the 'Move Up' or 'Move Down' arrows. If so, try to remove the indent so that the sites are flush to the left along with the heading. You'll probably see that the dropdown arrow and subsites now ...


3

After trying out different options available online, I was able to achieve it by JavaScript <!--SPM:<SharePoint:ScriptLink ID="ConfigurationScriptLink" Name="~sitecollection/SiteAssets/js/Configurations.js" runat="server"/>--> CSS <!--SPM:<SharePoint:CssRegistration ID="CSSCustom" Name="&lt;% ...


0

Try this: <img src="/Style Library/Images/logo.jpg" /> See this for more info: How to use relative URL for image in Master Page?


0

Please trace the CSS classes responsible for the look and feel of the list view web part using any browser's developer tool. Override those CSS classes in a custom stylesheet. Then either refer it in the masterpage (to make it effective globally) or refer it in specific contols (web part / app part).


1

Yes you can do this in master page. The only downside is it will have a global effect. Below is the CSS you can try with .ms-vh2 { background-color: green; } You can also look into the option of creating a JSLink and tie it to the ListTypes in question.


0

You can right-click on master page in SPD to make it as default or custom master page for the site.


0

for your firt quetion: I have been create the next css On my seattle.html I add this line: And the result is this: second question: try to add your css just above the head closing tag, because as you know html and css are sequentials so all your styles will be overwritten if another css execute after yours. third question: to this apply the answer ...


0

Your steps are correct, except the number 4, I recommend you leaving it only as custom master page and not as default. If you leave it as default, all pages of lists and settings will look under the new design and you can lose functionalities under the new design.


0

I can confirm your assumptions. What you want to do is select seattle.HTML in SPD, hold CTRL + Drag and this will create a copy of the HTML file. This automatically generates the .Master file which you can customize and make the default master page if you like. As far as I know, there is no upgrade that would overwrite your customized Master Page. In 2013, ...


0

There are multiple ways to create a Master Page. The way you explained is one among them. The steps are valid. But as per 2013 best practices you should use HTML file. You will not face any problems with upgrade (Provided Microsoft is not going to make drastic changes to the content placeholders) No. Instead using design manager copy the corresponding HTML ...


1

You can use HTML master pages in 2013. Download starter HTML master page from http://startermasterpages.codeplex.com/releases/view/97062 Browse to your publishing site. In the upper-right corner of the page, choose Settings, and then choose Design Manager. In Design Manager, in the left navigation pane, choose Edit Master Pages. Choose Convert an HTML file ...


0

Data attributes are not a part of the XHTML specification hence the error that you are seeing. If you don't need to comply with the XHTML specification you can simply ignore the error. Otherwise you would have to use HTML5 instead.


0

You can hide them by using below javascript $(document).ready(notRequiredElement); function notRequiredElement() { $("a[id$='_share_button']").css("display", "none"); $("a[id$='_SyncPromotedAction']").css("display", "none"); } Where id$='_share_button' represent any element that end with _share_button You can find more selector ...


0

The issue related to O365 and style updates being applied. Our front-end team creating a separate styling sheet solved the problem.



Top 50 recent answers are included