Hot answers tagged

5

You will need Full Control permission level to be able to edit a MasterPage in SharePoint Designer 2010. Reference: User permissions and permission levels (SharePoint Foundation 2010)


3

If your site is publishing site follow the mentioned steps below: Upload the CSS file to your style library then Go to Site Settings > Look and Feel > Design Manager > Publish and Apply design > Specify the path of CSS


1

Try to add this CSS code to your Page Layout <Style> body #s4-leftpanel { display: none; } .s4-ca { margin-left: 0px; } </style> For 2013 try this .ms-core-sideNavBox-removeLeftMargin { display: none } /* hide only quick links */ #contentBox { margin-left: 0px } /* make content take full page width */ After more investigation ...


1

I think the issue is here , as you said the new one is created in SharePoint designer and the old one is deployed through a wsp. You should modify your master page via the visual studio then deploy it again . to let this control registered as safe in Web.Config. you current method only working if master page branded with SP designer, not visual ...


1

Did you tried using the $SPUrl:~SiteCollection, you can specify a parameter which will return the current site collection <!--SPM:<SharePoint:CssRegistration name="&lt;% $SPUrl:~sitecollection/_catalogs/masterpage/Style Library/Custom.css %&gt;" runat="server" />-->



Only top voted, non community-wiki answers of a minimum length are eligible