Tag Info

Hot answers tagged

3

Yes It shares this quality as SharePoint online also has lookup column threshold of 8. https://community.office365.com/en-us/f/148/t/11914


1

Following query should return Look up fields /_api/web/lists/getByTitle('Your List Name')/Fields?$filter=TypeShortDescription eq 'Lookup (information already on this site)' Conditions it will not work if you put ant custom description! Update following will work in all scenario, I hope /_api/web/lists/getByTitle('Your List ...


1

To determine which fields are lookups you could take each field that is returned, e.g. "Field1", "Field2", "w9ft", "q37c", "Field5" and for each of these fields make REST calls to ascertain their type, like so: http://<myurl>/_api/Web/Lists/getByTitle('MyList')/Fields?$select=TypeAsString&$filter=Title eq 'w9ft' Or you can filter on the field's ...


1

You can use: string value = (new SPFieldLookupValue(item["FieldName"] as String)).LookupValue


1

If it's posible. Here are the steps: Create a list in the root site. Create a site column (of type lookup) in the root site referencing the list created in step 1. In the sub site, in a list, create a column using the "Add from existing site columns" And ready. Learn more in this article: Create a SharePoint Lookup Column to Another Site


1

If you're using SharePoint Foundation 2010, then this is a known issue where a custom list has a lookup field to another custom list that contains more than 20 items. If you set the value of the lookup field to "None," then you'll get the error. It looks like you'll need to apply an update to SharePoint to resolve the error. Here's more info: ...


1

select above should be: substring-before(substring-after(@Lookup, '&gt;'), '&lt;/a&gt;')


1

1- one solution is to use XPath functions to extract the simple inner text. see below sample <xsl:value-of select="substring-before( substring-after(@Service_, '&gt;') , '&lt;') "/> you can use some useful auto-complete XPath editor or more advanced editor in ribbon (see below image) 2- note the disable-output-escaping="yes" attribute ...



Only top voted, non community-wiki answers of a minimum length are eligible