Tag Info

New answers tagged

0

The problem was that sp.js and sp.runtime.js files were being referenced locally(ofcourse not the suggested way), which won't work well if SPO has update on those files. After adding the new CDN reference and removing the local reference it works fine.


1

The general guidance from the PnP group is no, there are other supported approaches to do the desired customizations without modifying the master page. That being said, they say if you are going to do it, you have to understand the risks of doing so. As soon as you break away, you aren't getting the updates and new features as they are implemented.


0

Make sure your custom master page has the all related scripts like <script type="text/javascript" src="/_layouts/15/sp.runtime.js"></script> <script type="text/javascript" src="/_layouts/15/sp.js"></script> <script type="text/javascript" src="/_layouts/15/sp.init.js?rev=jvJC3Kl5gbORaLtf7kxULQ%3D%3D"></script> ...


0

I know it's been a few years, but I found a good solution to this. You have them insert a normal image into a containing div, and then you use this jquery: $(function() { $(".header_image img").each(function(i, elem) { var img = $(elem); var div = $("<div />").css({ background: "url(" + img.attr("src") + ") no-repeat", ...


1

Try something like this - Target the "s4-ribbonrow" div Hide this div, may be by using inline-style Locate the end of "s4-ribbonrow" div Add this snippet after that div - < Sharepoint:SPSecurityTrimmedControl ID="SPSecurityTrimmedControl2" runat="server" PermissionsString="AddAndCustomizePages"> < script type="text/javascript"> ...


0

You can resetting the master page for all sites within the site collection: (requires publishing feature enabled) Site Settings Master Page (under Look & Feel) Select the master page for both Site and System and check "Reset all subsites..." Save Now that all sites are using your custom master page, you can do the following to set the master page ...



Top 50 recent answers are included